HDOJ 1041 Computer Transformation

Computer Transformation

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 7022    Accepted Submission(s): 2550


Problem Description
A sequence consisting of one digit, the number 1 is initially written into a computer. At each successive time step, the computer simultaneously tranforms each digit 0 into the sequence 1 0 and each digit 1 into the sequence 0 1. So, after the first time step, the sequence 0 1 is obtained; after the second, the sequence 1 0 0 1, after the third, the sequence 0 1 1 0 1 0 0 1 and so on. 

How many pairs of consequitive zeroes will appear in the sequence after n steps? 
 

Input
Every input line contains one natural number n (0 < n ≤1000).
 

Output
For each input n print the number of consecutive zeroes pairs that will appear in the sequence after n steps.
 

Sample Input
  
  
2 3
 

Sample Output
  
  
1 1
 

递推:0->10  ;
         1->01;
         00->1010;
         10->0110;
          01->1001;
          11->0101;

假设a[i]表示第i 步时候的00的个数,由上面的可以看到,00是由01 得到的,所以只要知道a[i-1]的01的个数就能够知道a[i]的00的个数了,那a[i-1]怎么求呢,同样看推导,01由1和00 得到,而第i步1的个数是2^(i-1),所以a[i]=2^(i-3)+a[i-2];


#include <iostream>
#include <cstdio>
#include <string>

using namespace std;

string add(string s1, string s2)  //大数 s1 + s2
{
    if (s1.length() < s2.length()){
        string temp = s1;
        s1 = s2;
        s2 = temp;
    }
    for (int i = s1.length() - 1, j = s2.length() - 1; i >= 0; i--, j--){
        s1[i] = char(s1[i] + (j >= 0 ? s2[j] - '0' : 0));
        if (s1[i] - '0' >= 10){
            s1[i] = char((s1[i] - '0') % 10 + '0');
            if (i) s1[i - 1]++;
            else s1 = "1" + s1;
        }
    }
    return s1;
}

string f[1005];
int main()
{
    int n;
    f[1] = "0"; f[2] = "1"; f[3] = "1"; f[4] = "3"; f[5] = "5"; f[6] = "11";
    //f[i]=f[i-1]+2*f[i-2];
    for (int i = 7; i <= 1004; i++)
        f[i] = add(f[i - 1], add(f[i - 2], f[i - 2]));
    while (scanf("%d", &n) == 1)
        cout << f[n] << endl;
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值