POJ 3734 Blocks (矩阵的幂)

Blocks
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 5335 Accepted: 2494

Description

Panda has received an assignment of painting a line of blocks. Since Panda is such an intelligent boy, he starts to think of a math problem of painting. Suppose there are N blocks in a line and each block can be paint red, blue, green or yellow. For some myterious reasons, Panda want both the number of red blocks and green blocks to be even numbers. Under such conditions, Panda wants to know the number of different ways to paint these blocks.

Input

The first line of the input contains an integer T(1≤T≤100), the number of test cases. Each of the next T lines contains an integer N(1≤N≤10^9) indicating the number of blocks.

Output

For each test cases, output the number of ways to paint the blocks in a single line. Since the answer may be quite large, you have to module it by 10007.

Sample Input

2
1
2

Sample Output

2
6

题意:

给定N个方块排成一列。现在要用红、蓝、绿、黄四种颜色的油漆给这些方块染色。求染成红色的方块和染成绿色的方块的个数同时为偶数的染色方案的个数,输出对10007取余后的答案。


分析:

我们试着从左边开始一次染色。设染到第i个方块为止,红绿都是偶数的方案数为ai,红绿恰有一个是偶数的方案数为bi,红绿都是奇数的方案数为ci。这样,染到第i+1个方块为止,红绿都是偶数的方案数有如下两种可能

*到第i个方块为止红绿都是偶数,并且第i+1个方块染成了蓝色或者黄色

*到第i个方块为止红绿恰有一个是奇数,并且第i+1个方块染成了奇数个对应的那种颜色,因此有如下递推式

ai+1 = 2*ai + bi

同样的,有

bi+1 = 2*ai + 2*bi + 2*ci

ci+1 = bi + 2*ci

把ai,bi,ci的递推式用矩阵表示如下

 

因此就有


这样,用和之前一样的方法计算矩阵的幂就可以求出这个问题的答案了。

#include <cstdio>
#include <vector>
using namespace std;
typedef vector<int> vec;
typedef vector<vec> mat;
const int M = 10007;

int t, N;

//计算A*B
mat mul(mat &A, mat &B)
{
    mat C(A.size(), vec(B[0].size()));
    for (int i = 0; i < A.size(); i++){
        for (int k = 0; k < B.size(); k++){
            for (int j = 0; j < B[0].size(); j++){
                C[i][j] = (C[i][j] + A[i][k] * B[k][j]) % M;
            }
        }
    }
    return C;
}

//计算A ^ n
mat pow(mat A, int n)
{
    mat B(A.size(), vec(A.size()));
    for (int i = 0; i < A.size(); i++){
        B[i][i] = 1;
    }
    while (n > 0){
        if (n & 1)
            B = mul(B, A);
        A = mul(A, A);
        n >>= 1;
    }
    return B;
}

void solve()
{
    mat A(3, vec(3));
    A[0][0] = 2;
    A[0][1] = 1;
    A[0][2] = 0;
    A[1][0] = 2;
    A[1][1] = 2;
    A[1][2] = 2;
    A[2][0] = 0;
    A[2][1] = 1;
    A[2][2] = 2;

    A = pow(A, N);
    printf("%d\n", A[0][0]);
}

int main()
{
    scanf("%d", &t);
    while (t--){
        scanf("%d", &N);
        solve();
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值