POJ3026(BFS + prim)

Borg Maze
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 10554 Accepted: 3501

Description

The Borg is an immensely powerful race of enhanced humanoids from the delta quadrant of the galaxy. The Borg collective is the term used to describe the group consciousness of the Borg civilization. Each Borg individual is linked to the collective by a sophisticated subspace network that insures each member is given constant supervision and guidance.  

Your task is to help the Borg (yes, really) by developing a program which helps the Borg to estimate the minimal cost of scanning a maze for the assimilation of aliens hiding in the maze, by moving in north, west, east, and south steps. The tricky thing is that the beginning of the search is conducted by a large group of over 100 individuals. Whenever an alien is assimilated, or at the beginning of the search, the group may split in two or more groups (but their consciousness is still collective.). The cost of searching a maze is definied as the total distance covered by all the groups involved in the search together. That is, if the original group walks five steps, then splits into two groups each walking three steps, the total distance is 11=5+3+3.

Input

On the first line of input there is one integer, N <= 50, giving the number of test cases in the input. Each test case starts with a line containg two integers x, y such that 1 <= x,y <= 50. After this, y lines follow, each which x characters. For each character, a space `` '' stands for an open space, a hash mark ``#'' stands for an obstructing wall, the capital letter ``A'' stand for an alien, and the capital letter ``S'' stands for the start of the search. The perimeter of the maze is always closed, i.e., there is no way to get out from the coordinate of the ``S''. At most 100 aliens are present in the maze, and everyone is reachable.

Output

For every test case, output one line containing the minimal cost of a succesful search of the maze leaving no aliens alive.

Sample Input

2
6 5
##### 
#A#A##
# # A#
#S  ##
##### 
7 7
#####  
#AAA###
#    A#
# S ###
#     #
#AAA###
#####  

Sample Output

8
11
题意:求每个字母彼此之间的距离,找到一条最短路径将所有字母相连。
思路:用BFS枚举每个字母之间的距离,再用prim求出最短的一条路径。
收获:了解了prim要初始化和1相连的边权。
这题还要再做一遍。
#include <cstdio>
#include <iostream>
#include <cstdlib>
#include <algorithm>
#include <ctime>
#include <cmath>
#include <string>
#include <cstring>
#include <stack>
#include <queue>
#include <list>
#include <vector>
#include <map>
#include <set>
using namespace std;

const int INF=0x3f3f3f3f;
const double eps=1e-10;
const double PI=acos(-1.0);
#define maxn 1000
struct Node
{
    int x, y, dis;
};
Node st, et;
int vis[maxn][maxn];
char map1[maxn][maxn];
int vis2[maxn];
int node[maxn][maxn];
int edge[maxn][maxn];
int dis[maxn];
int pre[maxn];
int dx[] = {0, 0, -1, 1};
int dy[] = {1, -1, 0 ,0};
int sum, n, m;
void bfs(int i, int j)
{
    memset(vis, 0, sizeof vis);
    queue<Node> q;
    Node st = {i, j, 0};
    vis[i][j] = 1;
    q.push(st);
    while(!q.empty())
    {
        Node t = q.front();
        q.pop();
        if(node[t.x][t.y])
            edge[node[st.x][st.y]][node[t.x][t.y]] = t.dis;
        for(int i = 0; i < 4; i++)
        {
            int x0 = t.x + dx[i];
            int y0 = t.y + dy[i];
            if(!vis[x0][y0] && map1[x0][y0] != '#' && x0>=0 && x0 < m && y0 >= 0 && y0 < n)
            {
                vis[x0][y0] = 1;
                Node f = {x0,  y0, t.dis+1};
                q.push(f);
            }
        }
    }

}
int low[maxn];
int Prim()
{
    int s=1,i,count=1,prim_sum=0,t;
    bool flag[maxn]={false};
    flag[s] = true;
    for(i=1; i<=sum; i++)
        low[i] = 99999;
    while(count < sum)
    {
        int min_dis = 99999;
        for(i=1; i<=sum; i++)
        {
            if(!flag[i] && low[i]>edge[s][i])
                low[i] = edge[s][i];
            if(!flag[i] && low[i]<min_dis)
            {
                min_dis = low[i];
                t = i;
            }
        }
        s = t; count++;
        flag[s] = true;
        prim_sum += min_dis;
    }
    return prim_sum;
}

int main()
{
    int t;
    scanf("%d", &t);
    while(t--)
    {
        scanf("%d%d", &n, &m);
        char temp[50];
        gets(temp);
        sum = 0;
        memset(node, 0, sizeof node);
        memset(edge, 0, sizeof edge);
        for(int i = 0; i < m; i++)
        {
            gets(map1[i]);
            for(int j = 0; j < n; j++)
            {
                if(map1[i][j] == 'S' || map1[i][j] == 'A')
                    node[i][j] = ++sum;
            }
        }
        for(int i = 0; i < m; i++)
            for(int j = 0; j < n; j++)
                if(node[i][j])
                bfs(i, j);
         printf("%d\n", Prim());
    }
    return 0;
}

 

转载于:https://www.cnblogs.com/ZP-Better/p/4734316.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值