HDU 4324

3 篇文章 0 订阅

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=4324

Triangle LOVE

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 2520    Accepted Submission(s): 1025


Problem Description
Recently, scientists find that there is love between any of two people. For example, between A and B, if A don’t love B, then B must love A, vice versa. And there is no possibility that two people love each other, what a crazy world!
Now, scientists want to know whether or not there is a “Triangle Love” among N people. “Triangle Love” means that among any three people (A,B and C) , A loves B, B loves C and C loves A.
  Your problem is writing a program to read the relationship among N people firstly, and return whether or not there is a “Triangle Love”.
 

Input
The first line contains a single integer t (1 <= t <= 15), the number of test cases.
For each case, the first line contains one integer N (0 < N <= 2000).
In the next N lines contain the adjacency matrix A of the relationship (without spaces). A i,j = 1 means i-th people loves j-th people, otherwise A i,j = 0.
It is guaranteed that the given relationship is a tournament, that is, A i,i= 0, A i,j ≠ A j,i(1<=i, j<=n,i≠j).
 

Output
For each case, output the case number as shown and then print “Yes”, if there is a “Triangle Love” among these N people, otherwise print “No”.
Take the sample output for more details.
 

Sample Input
  
  
2 5 00100 10000 01001 11101 11000 5 01111 00000 01000 01100 01110
 

Sample Output
  
  
Case #1: Yes Case #2: No
 

Author
BJTU
 

Source
 
  题意:询问是否存在仅由三个点组成的环。
       解法:这题可以用拓扑排序的方法写,我用的是tarjan,在得到的强连通分量中找点是否大于等于3个,若有则必定有仅由三个点组成的环。时间复杂度O(N^2)。
/*************************************************************************
    > File Name: HDU/4324.cpp
    > Author: magicyang
    > Mail:273868471@qq.com
    > Created Time: 2014年09月01日 星期一 16时31分06秒
 ************************************************************************/

#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<algorithm>
#include<queue>
#include<vector>
#include<stack>
using namespace std;
vector<int>g[2005];
stack<int>s;
int pre[2005],lowlink[2005],scc[2005],dfs_clk,scc_cnt;
int flag;
void dfs(int u)
{
    pre[u]=lowlink[u]=++dfs_clk;
    s.push(u);
    for(int i=0;i<g[u].size();i++)
    {
        int v=g[u][i];
        if(!pre[v])
        {
            dfs(v);
            lowlink[u]=min(lowlink[u],lowlink[v]);
        }
        else if(!scc[v])
        {
            lowlink[u]=min(lowlink[u],pre[v]);
        }
    }
    if(lowlink[u]==pre[u])
    {
        scc_cnt++;
        int ans=0;
        for(;;)
        {
            int x=s.top();
            s.pop();
            ans++;
            scc[x]=scc_cnt;
            if(ans>=3) 
            {
                flag=1;
                return ;
            }
            if(x==u) break;
        }
    }
}
void find(int n)
{
    while(!s.empty()) s.pop();
    dfs_clk=scc_cnt=0;
    memset(scc,0,sizeof scc);
    memset(pre,0,sizeof pre);
    for(int i=1;i<=n;i++)
    {
        if(!pre[i])
            dfs(i);
        if(flag==1) return ;
    }
    return ;
}
char ss[2005];
int main()
{
    int t,ca=0;
    scanf("%d",&t);
    while(t--)
    {
        int n;
        flag=0;
        scanf("%d",&n);
        for(int i=1;i<=n;i++)
            g[i].clear();
        for(int i=0;i<n;i++)
        {
            scanf("%s",ss);
            int l=strlen(ss);
            for(int j=0;j<l;j++)
            {
                if(ss[j]=='1')
                    g[i+1].push_back(j+1);
            }
        }
        printf("Case #%d: ",++ca);
        find(n);
        if(flag==1) printf("Yes\n");
        else printf("No\n");
    }
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值