hdu 5773 The All-purpose Zero (LIS)

The All-purpose Zero

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 2727    Accepted Submission(s): 1212


 

Problem Description

?? gets an sequence S with n intergers(0 < n <= 100000,0<= S[i] <= 1000000).?? has a magic so that he can change 0 to any interger(He does not need to change all 0 to the same interger).?? wants you to help him to find out the length of the longest increasing (strictly) subsequence he can get.

 

 

Input

The first line contains an interger T,denoting the number of the test cases.(T <= 10)
For each case,the first line contains an interger n,which is the length of the array s.
The next line contains n intergers separated by a single space, denote each number in S.

 

 

Output

For each test case, output one line containing “Case #x: y”(without quotes), where x is the test case number(starting from 1) and y is the length of the longest increasing subsequence he can get.

 

 

Sample Input

 

2 7 2 0 2 1 2 0 5 6 1 2 3 3 0 0

 

 

Sample Output

Case #1: 5 Case #2: 5

思路:可以先把0挑出来,然后不为零的数减去这个数前面为0的个数存到数组里,找出最长上升子序列再加上零的个数即可;

代码:

#include <iostream>
#include <stdio.h>
#include <string.h>
#include <algorithm>
#define INF 0x3f3f3f
using namespace std;
int a[100005];
int dp[100005];
int main()
{
    int T;
    cin>>T;
    int t=1;
    while(T--)
    {
        int n;
        cin>>n;
        int i;
        int sum=0;
        int m;
        int k=1;
        for(i=0;i<n;i++)
        {
            scanf("%d",&m);
            if(m==0)sum++;
            else  a[k++]=m-sum;
        }
        if(k==1)
        {
            cout<<"Case #"<<t++<<": "<<n<<endl;
            continue;
        }
        memset(dp,0x3f,sizeof(dp));
        int len=0;
        for(i=1;i<k;i++)
        {
            int x=lower_bound(dp,dp+k,a[i])-dp;
            dp[x]=a[i];
            if(x+1>len)
                len=x+1;
        }
        printf("Case #%d: ", t++);
        cout<<len+sum<<endl;
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值