POJ 1001-Exponentiation(NYOJ 155 求高精度幂):大数问题

点击打开链接

Exponentiation
Time Limit: 500MS Memory Limit: 10000K
Total Submissions: 120472 Accepted: 29411

Description

Problems involving the computation of exact values of very large magnitude and precision are common. For example, the computation of the national debt is a taxing experience for many computer systems. 

This problem requires that you write a program to compute the exact value of R n where R is a real number ( 0.0 < R < 99.999 ) and n is an integer such that 0 < n <= 25.

Input

The input will consist of a set of pairs of values for R and n. The R value will occupy columns 1 through 6, and the n value will be in columns 8 and 9.

Output

The output will consist of one line for each line of input giving the exact value of R^n. Leading zeros should be suppressed in the output. Insignificant trailing zeros must not be printed. Don't print the decimal point if the result is an integer.

Sample Input

95.123 12
0.4321 20
5.1234 15
6.7592  9
98.999 10
1.0100 12

Sample Output

548815620517731830194541.899025343415715973535967221869852721
.00000005148554641076956121994511276767154838481760200726351203835429763013462401
43992025569.928573701266488041146654993318703707511666295476720493953024
29448126.764121021618164430206909037173276672
90429072743629540498.107596019456651774561044010001
1.126825030131969720661201

Hint

If you don't know how to determine wheather encounted the end of input: 
s is a string and  n is an integer 

大数问题,而且需要注意的地方比较多,以前做的了,有些细节可能想不全,想到哪些再不上吧

1.整数部分,头部的0可以去掉,小数部分,尾部的0可以去掉

2.运算选忽略小数点,当做整数运算,最后再移动小数点的位置

#include<stdio.h>
#include<stdlib.h>
#include<string.h>
int result[1001];
char a[11];
int top1, top2;

void fun(int num)
{
	int i, j;
	for(i = 0; i < top1; i++)
	{
		result[i] = result[i] * num;
	}
	for(i = 0; i < top1; i++)
	{
		result[i + 1] += result[i] /10;
		result[i] = result[i] % 10;
		if(i + 1 == top1 && result[i + 1] != 0)
			top1 ++;
	}
}

int main()
{
	int flag;
	char str[11];
	int num;
	int n;
	int i;
	int len;
	double number;
	while(~scanf("%s", str))
	{
		scanf("%d", &num);
		flag = -1;
		number = atof(str);
		sprintf(str, "%.10g", number);
		len = strlen(str);
		top1 = 1;
		top2 = 0;
		result[0] = 1;
		for(i = 0; str[i]; i++)
		{
			if(str[i] =='.')
				flag = i;
			else 
			{
				a[top2++] = str[i];
			}
		}
		if(flag != -1)
		{
			flag = len - (flag + 1);
			flag *= num;
		}
		n = atoi(a);
		for(i = 0; i < num; i ++)
		{
			fun(n);
		}
		if(top1 - 1 < flag)
			printf(".");
		for(i = flag - top1; i> 0; i --)
			printf("0");
		for(i = top1 - 1; i >= 0; i--)
		{
			if((i + 1) == flag)
				printf(".");
			printf("%d", result[i]);
		}
		printf("\n");
		memset(a, 0, sizeof(a));
		memset(result, 0, sizeof(result));
		
	}
	return 0;
}        


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
Problems involving the computation of exact values of very large magnitude and precision are common. For example, the computation of the national debt is a taxing experience for many computer systems. This problem requires that you write a program to compute the exact value of Rn where R is a real number ( 0.0 < R < 99.999 ) and n is an integer such that 0 < n <= 25. 输入说明 The input will consist of a set of pairs of values for R and n. The R value will occupy columns 1 through 6, and the n value will be in columns 8 and 9. 输出说明 The output will consist of one line for each line of input giving the exact value of R^n. Leading zeros should be suppressed in the output. Insignificant trailing zeros must not be printed. Don't print the decimal point if the result is an integer. 输入样例 95.123 12 0.4321 20 5.1234 15 6.7592 9 98.999 10 1.0100 12 输出样例 548815620517731830194541.899025343415715973535967221869852721 .00000005148554641076956121994511276767154838481760200726351203835429763013462401 43992025569.928573701266488041146654993318703707511666295476720493953024 29448126.764121021618164430206909037173276672 90429072743629540498.107596019456651774561044010001 1.126825030131969720661201 小提示 If you don't know how to determine wheather encounted the end of input: s is a string and n is an integer C++ while(cin>>s>>n) { ... } c while(scanf("%s%d",s,&n)==2) //to see if the scanf read in as many items as you want /*while(scanf(%s%d",s,&n)!=EOF) //this also work */ { ... } 来源 East Central North America 1988 北大OJ平台(代理
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

勇敢的炮灰

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值