HDU4496 D-City【并查集】

D-City

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65535/65535 K (Java/Others)
Total Submission(s): 5694    Accepted Submission(s): 2002

 

Problem Description

Luxer is a really bad guy. He destroys everything he met. 
One day Luxer went to D-city. D-city has N D-points and M D-lines. Each D-line connects exactly two D-points. Luxer will destroy all the D-lines. The mayor of D-city wants to know how many connected blocks of D-city left after Luxer destroying the first K D-lines in the input. 
Two points are in the same connected blocks if and only if they connect to each other directly or indirectly.

Input

First line of the input contains two integers N and M. 
Then following M lines each containing 2 space-separated integers u and v, which denotes an D-line. 
Constraints: 
0 < N <= 10000 
0 < M <= 100000 
0 <= u, v < N. 

Output

Output M lines, the ith line is the answer after deleting the first i edges in the input.

Sample Input

5 10 
0 1 
1 2 
1 3 
1 4 
0 2 
2 3 
0 4 
0 3 
3 4 
2 4

Sample Output

1 
1 
1 
2 
2 
2 
2 
3 
4 
5

Hint

The graph given in sample input is a complete graph, that each pair of vertex has an edge connecting them, so there's only 1 connected block at first. The first 3 lines of output are 1s because after deleting the first 3 edges of the graph, all vertexes still connected together. But after deleting the first 4 edges of the graph, vertex 1 will be disconnected with other vertex, and it became an independent connected block. Continue deleting edges the disconnected blocks increased and finally it will became the number of vertex, so the last output should always be N.

Source

2013 ACM-ICPC吉林通化全国邀请赛——题目重现

问题链接:HDU4496 D-City

问题描述:N个结点(从0开始编号),M条无向边,输出M个数,分别表示删去第i条边后,有多少个连通块

解题思路:并查集,加边(先加编号大的边),开始共有N个连通块,每添加一条边,如果这条边的两个端点不相连,那么添加这条边后连通块个数减一。具体看程序。注意:多组输入

AC的C++程序:

#include<iostream>

using namespace std;

const int N=10010;

struct Edge{
	int a,b;
}e[N*10];

int pre[N],ans[N*10];

void init(int n)
{
	for(int i=0;i<n;i++)
		pre[i]=i;
}

int find(int x)
{
	if(x!=pre[x])
	  pre[x]=find(pre[x]);
	return pre[x];
}

bool join(int x,int y)
{
	int fx=find(x);
	int fy=find(y);
	if(fx!=fy){
		pre[fx]=fy;
		return true;
	}
	return false;
}

int main()
{
	int n,m,a,b,count;
	while(~scanf("%d%d",&n,&m)){
		count=n;
		init(n);
		for(int i=1;i<=m;i++)
	  	  scanf("%d%d",&e[i].a,&e[i].b);
		ans[m]=count;
		for(int i=m;i>0;i--){
			if(join(e[i].a,e[i].b))
			  count--;
			ans[i-1]=count;
		}
		for(int i=1;i<=m;i++)
	  	  printf("%d\n",ans[i]);
	}	 
	return 0;
}


 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值