并查集--HDU - 4496 D-City

Description

Luxer is a really bad guy. He destroys everything he met. 
One day Luxer went to D-city. D-city has N D-points and M D-lines. Each D-line connects exactly two D-points. Luxer will destroy all the D-lines. The mayor of D-city wants to know how many connected blocks of D-city left after Luxer destroying the first K D-lines in the input. 
Two points are in the same connected blocks if and only if they connect to each other directly or indirectly.
 

Input

First line of the input contains two integers N and M. 
Then following M lines each containing 2 space-separated integers u and v, which denotes an D-line. 
Constraints: 
0 < N <= 10000 
0 < M <= 100000 
0 <= u, v < N. 
 

Output

Output M lines, the ith line is the answer after deleting the first i edges in the input.
 

Sample Input

    
    
5 10 0 1 1 2 1 3 1 4 0 2 2 3 0 4 0 3 3 4 2 4
 

Sample Output

    
    
1 1 1 2 2 2 2 3 4 5


分析:逆向并查集,题已阐明会删除所有边,所以删完后的状态是每个点都是独立的集合,那么考察前一个状态,假设前面删的是u,v两点,查找并查集,如果u,v同集则说明删除u,v边后增加了集合数量,否则对集合数量没有影响。实际上是对输入数据的逆向判断。


#include <cstdio>
#include <cstring>
using namespace std;
const int maxn = 10000 + 10;
const int maxe = 100000 + 10;
struct edge { int u, v; };
int p[maxn];
edge e[maxe];
int ans[maxe];

int find_set(int x)
{
    int r = x;
    while(r != p[r]) r = p[r];
    while(x != r) {
        int tmp = p[x];
        p[x] = r;
        x = tmp;
    }
    return x;
}

int main()
{
	int n, m;
	while(~scanf("%d%d", &n, &m)) {
		memset(ans, 0, sizeof(ans));
		for(int i=0; i<n; i++) p[i] = i;
		for(int i=0; i<m; i++) scanf("%d%d", &e[i].u, &e[i].v);
		ans[m-1] = n;
        for(int i=m-1; i>0; i--) {
			int x = find_set(e[i].u);
			int y = find_set(e[i].v);
			if(x != y) {
				p[x] = y;
				ans[i-1] = ans[i] - 1;
			} else ans[i-1] = ans[i];
        }
        for(int i=0; i<m; i++) printf("%d\n", ans[i]);
	}
    return 0;
}


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值