Tautology

H - Tautology
Time Limit:1000MS     Memory Limit:65536KB     64bit IO Format:%lld & %llu

Description

WFF 'N PROOF is a logic game played with dice. Each die has six faces representing some subset of the possible symbols K, A, N, C, E, p, q, r, s, t. A Well-formed formula (WFF) is any string of these symbols obeying the following rules:

  • p, q, r, s, and t are WFFs
  • if w is a WFF, Nw is a WFF
  • if w and x are WFFs, Kwx, Awx, Cwx, and Ewx are WFFs.
The meaning of a WFF is defined as follows:
  • p, q, r, s, and t are logical variables that may take on the value 0 (false) or 1 (true).
  • K, A, N, C, E mean and, or, not, implies, and equals as defined in the truth table below.
Definitions of K, A, N, C, and E
     w  x  Kwx  Awx   Nw  Cwx  Ewx
  1  1  1  1   0  1  1
  1  0  0  1   0  0  0
  0  1  0  1   1  1  0
  0  0  0  0   1  1  1

tautology is a WFF that has value 1 (true) regardless of the values of its variables. For example, ApNp is a tautology because it is true regardless of the value of p. On the other hand, ApNq is not, because it has the value 0 for p=0, q=1.

You must determine whether or not a WFF is a tautology.

Input

Input consists of several test cases. Each test case is a single line containing a WFF with no more than 100 symbols. A line containing 0 follows the last case.

Output

For each test case, output a line containing tautology or not as appropriate.

Sample Input

ApNp
ApNq
0

Sample Output

tautology
not


思路,枚举所有p,q,r,s,t的值情况,然后判定这个式子的值,有一种取值情况使其为零,就不是重言式;

用递归判定

终止条件是遇到变量返回变量值

eg:ANqKqp    第一次递归是‘A’  t1赋值进入第二个递归,得到nq的值,同时flog[1,2]赋零,先找到t2赋值进入递归的开始位置,也就是k的位置,进入递归,得到新的t1,t2的值按照K要求的返回Kqp的值,给第一次递归里的t2;  此时t1是Nq的值,t2是Kqp的值,按照A要求返回At1t2的值,也就是原式的值; 

#include<stdio.h>
#include<string.h>
char ch[200];
int p,q,r,s,t;
bool flog[200];//标记作用
int dfs(int x);
int main()
{
	int len,index;
	while(scanf("%s",ch)!=EOF)
	{
		index=1;
		
		len=strlen(ch);
		if(len==1&&ch[0]=='0')
		break;
		for(q=0;q<2;q++)
		{
			for(p=0;p<2;p++)
			{
				for(r=0;r<2;r++)
					{
						for(s=0;s<2;s++)
							{
								for(t=0;t<2;t++)
									{
										for(int i=0;i<200;i++)
										flog[i]=1;
										if(dfs(0)==0)
										{
											index=0;
											break;
										}
									}
							}
					}
			}
		}
		if(index)
		printf("tautology\n");
		else
		printf("not\n");
	}
}
int dfs(int x)
{
	int t1,t2,x1;
	while(flog[x]==0){
		x++;
	}
	x1=x;
	flog[x1]=0;
	if(ch[x1]>='A'&&ch[x1]<='Z')
	{
		t1=dfs(++x1);
		if(ch[x]=='N')
		{
			return !t1;
		}
		else
		{
			while(flog[x1]==0)
			{
				x1++;
			}
			t2=dfs(x1);
			if(ch[x]=='K')
			{
				if(t1==1&&t2==1)
				return 1;
				else
				return 0;
			}
			else if(ch[x]=='A')
			{
			//	printf("%d %d\n",t1,t2);
				if(t1==0&&t2==0)
				return 0;
				else
				return 1;
			}
			else if(ch[x]=='C')
			{
				if(t1==1&&t2==0)
				return 0;
				else
				return 1;
			}
			else if(ch[x]=='E')
			{
				if(t1==t2)
				return 1;
				else
				return 0;
			}
		}
	}
	else if(ch[x]=='p')
	return p;
	else if(ch[x]=='q')
	return q;
	else if(ch[x]=='r')
	return r;
	else if(ch[x]=='s')
	return s;
	else if(ch[x]=='t')
	return t;
}





  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值