poj-3295 Tautology

4 篇文章 0 订阅

Description

WFF 'N PROOF is a logic game played with dice. Each die has six faces representing some subset of the possible symbols K, A, N, C, E, p, q, r, s, t. A Well-formed formula (WFF) is any string of these symbols obeying the following rules:

  • p, q, r, s, and t are WFFs
  • if w is a WFF, Nw is a WFF
  • if w and x are WFFs, Kwx, Awx, Cwx, and Ewx are WFFs.
The meaning of a WFF is defined as follows:
  • p, q, r, s, and t are logical variables that may take on the value 0 (false) or 1 (true).
  • K, A, N, C, E mean and, or, not, implies, and equals as defined in the truth table below.
Definitions of K, A, N, C, and E
     w  x  Kwx  Awx   Nw  Cwx  Ewx
  1  1  1  1   0  1  1
  1  0  0  1   0  0  0
  0  1  0  1   1  1  0
  0  0  0  0   1  1  1

A tautology is a WFF that has value 1 (true) regardless of the values of its variables. For example, ApNp is a tautology because it is true regardless of the value of p. On the other hand, ApNq is not, because it has the value 0 for p=0, q=1.

You must determine whether or not a WFF is a tautology.

Input

Input consists of several test cases. Each test case is a single line containing a WFF with no more than 100 symbols. A line containing 0 follows the last case.

Output

For each test case, output a line containing tautology or not as appropriate.

Sample Input

ApNp
ApNq
0

Sample Output

tautology
not

题意:

输入由p、q、r、s、t、K、A、N、C、E共10个字母组成的逻辑表达式,

其中p、q、r、s、t的值为1(true)或0(false),即逻辑变量;

K、A、N、C、E为逻辑运算符,

K --> and:  x && y

A --> or:  x || y

N --> not :  !x

C --> implies :  (!x)||y

E --> equals :  x==y

问这个逻辑表达式是否为永真式。

用p,q,r,s,t,的五层循环遍历这些值的真假情况,在一次遍历中逆向遍历输入的式子,如果是数值就压入栈中,如果是运算符就将栈顶元素提出经过运算再压回栈中。最后栈中只剩下一项,那一项的值就是表达式的值,如果遍历中出现表达式的值为假,表达式为永真式便不成立。

#include <stdio.h>
#include <string.h>
#include <stdlib.h>
#include <math.h>
#include <algorithm>
#include <iostream>

using namespace std;

int p,q,r,s,t;
bool sta[200];
char str[200];
int top;

void fun(char c)                                           //运算函数
{
    switch(c)
    {
            case 'K':
        {
            int x=sta[--top];
            int y=sta[--top];
            sta[top++]=(x&&y);
            break;
        }
            case 'A':
        {
            int x=sta[--top];
            int y=sta[--top];
            sta[top++]=(x||y);
            break;
        }
            case 'N':
        {
            int x=sta[--top];
            sta[top++]=!x;
            break;
        }
            case 'C':
        {
            int x=sta[--top];
            int y=sta[--top];
            sta[top++]=((!x)||y);
            break;
        }
            case 'E':
        {
            int x=sta[--top];
            int y=sta[--top];
            sta[top++]=(x==y);
            break;
        }
    }
}
void fun2(int i)                                          //压栈函数
{
    switch(str[i])
    {
    case 'p':
        {
            if(p)
                sta[top++]=true;
            else
                sta[top++]=false;
                break;
        }
            case 'q':
        {
            if(q)
                sta[top++]=true;
            else
                sta[top++]=false;
                break;
        }
            case 's':
        {
            if(s)
                sta[top++]=true;
            else
                sta[top++]=false;
                break;
        }
            case 'r':
        {
            if(r)
                sta[top++]=true;
            else
                sta[top++]=false;
                break;
        }
            case 't':
        {
            if(t)
                sta[top++]=true;
            else
                sta[top++]=false;
                break;
        }
    }
}
int main()
{
    int i;
    while (scanf("%s",str),str[0]!='0')
    {
        top=0;
        int len=strlen(str),flag=0;
        for (p=0;p<=1;p++)
        {
            for (q=0;q<=1;q++)
            {
                for (r=0;r<=1;r++)
                {
                    for (s=0;s<=1;s++)
                    {
                        for (t=0;t<=1;t++)
                        {
                            for (i=len-1;i>=0;i--)
                            {
                                if(str[i]=='p'||str[i]=='q'||str[i]=='s'||str[i]=='r'||str[i]=='t')
                                    fun2(i);
                                else
                                    fun(str[i]);
                            }
                            if(!sta[--top])
                            {
                                flag=1;
                                break;
                            }
                        }
                        if(flag) break;
                    }
                    if(flag) break;
                }
                if(flag) break;
            }
            if(flag) break;
        }
        if(!flag)
        {
            printf("tautology\n");
        }
        else printf("not\n");
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值