HDU1936--Counting Triangles

Description

Given an equilateral triangle with n the length of its side, program to count how many triangles in it.



 

Input

The length n (n <= 500) of the equilateral triangle's side, one per line.

process to the end of the file
 

Output

The number of triangles in the equilateral triangle, one per line.
 

Sample Input

       
       
1 2 3
 

Sample Output

       
       
1 5 13
 
/*此题的分析思路为边长为n的等边三角形,变为边长为n+1的等边三角形,边长为1的三角形增加了多少个,边长为2的三角形增加了多少个,
都是有规律的,注意三角形有上有下。。。*/
#include <iostream>
#include <cstdio>
using namespace std;
int A[508];
int main()
{
	A[1]=1;
	for(int i=2;i<=500;i++)
	{
		A[i]=A[i-1];
		A[i]+=2*i-1;
		for(int j=1;j<i;j++)
		{
			A[i]+=i-j;
		}//朝上
		for(int j=2;2*j<=i;j++)
		{
			A[i]+=i-2*j+1;
		}//在这里出的错
	}
	int n;
	while(scanf("%d",&n)!=EOF)
	{
		cout<<A[n]<<endl;
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值