HDU1396:Counting Triangles

Problem Description
Given an equilateral triangle with n the length of its side, program to count how many triangles in it.



 

Input
The length n (n <= 500) of the equilateral triangle's side, one per line.

process to the end of the file
 

Output
The number of triangles in the equilateral triangle, one per line.
 

Sample Input
  
  
1 2 3
 

Sample Output
  
  
1 5 13
 


 

递推:将前一个的三角形数+新增的两层大小的三角形数+新增的三层以上的三角形数就得出现在的三角形总数

 

#include <stdio.h>

int main()
{
    __int64 a[505];
    int i;
    int k;
    a[1] = 1;
    for(i = 2;i<=500;i++)
    {
        a[i] = a[i-1]+i*(i+1)/2;
        k = i-1;
        while(k>0)
        {
            a[i]+=k;
            k-=2;
        }
    }
    while(~scanf("%d",&k))
    {
        printf("%I64d\n",a[k]);
    }

    return 0;
}


 

  • 1
    点赞
  • 4
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值