What Is Your Grade?

What Is Your Grade?    HDU - 1084

“Point, point, life of student!”
This is a ballad(歌谣)well known in colleges, and you must care about your score in this exam too. How many points can you get? Now, I told you the rules which are used in this course.
There are 5 problems in this final exam. And I will give you 100 points if you can solve all 5 problems; of course, it is fairly difficulty for many of you. If you can solve 4 problems, you can also get a high score 95 or 90 (you can get the former(前者) only when your rank is in the first half of all students who solve 4 problems). Analogically(以此类推), you can get 85、80、75、70、65、60. But you will not pass this exam if you solve nothing problem, and I will mark your score with 50.
Note, only 1 student will get the score 95 when 3 students have solved 4 problems.
I wish you all can pass the exam!
Come on!

Input
Input contains multiple test cases. Each test case contains an integer N (1<=N<=100, the number of students) in a line first, and then N lines follow. Each line contains P (0<=P<=5 number of problems that have been solved) and T(consumed time). You can assume that all data are different when 0<p.
A test case starting with a negative integer terminates the input and this test case should not to be processed.

Output
Output the scores of N students in N lines for each case, and there is a blank line after each case.
Sample Input
4
5 06:30:17
4 07:31:27
4 08:12:12
4 05:23:13
1
5 06:30:17
-1
Sample Output
100
90
90
95

100


#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;

struct student
{
	int nu,q,u,gr;//nu代表最对的题,q代表输入时的顺序,u代表做对相同数量的题的同学中按时间的顺序
	int ti;       //gr代表成绩,ti代表时间
}s[105];

bool cmp(student a,student b)
{
	if(a.nu!=b.nu)   //最对题的数量相等时比较时间排序
	return a.nu>b.nu;
	else
	return a.ti<b.ti;
}

bool cmp2(student a,student b)
{
	return a.q<b.q;
}

int main()
{
	int n,a[6],f,i;
	char sti[10];
	while( ~scanf("%d",&n) && n > 0)
	{
		memset(a,0,sizeof(a));
		for( i = 0; i < n; i++)
		{
			scanf("%d%s",&s[i].nu,sti);a[s[i].nu]++;//a数组记录做对相同数量的题的人数
			s[i].ti = ((sti[0]-'0')*10 + sti[1]-'0')*3600 + ((sti[3]-'0')*10 + sti[4]-'0')*60 + ((sti[6]-'0')*10 + sti[7]-'0');//时间都统一用秒表示,
			s[i].q = i;
		}
		sort(s,s+n,cmp);//按得分排序
		f = 1;
		for( i = 0; i < n; i++)
		{
			s[i].u=f;//f代表在同类数量题的同学中的顺序
			if(s[i].nu != s[i + 1].nu) f = 1;
			else f++;
			if(s[i].nu == 5) s[i].gr=100;
			if(s[i].nu == 4) 
			{
				
				if(s[i].u <= a[4]/2)
				{
					s[i].gr=95;
				}
				else s[i].gr=90;
			}
			if(s[i].nu == 3) 
			{
				if(s[i].u <= a[3]/2)
				{
					s[i].gr=85;
				}
				else s[i].gr=80;
			}
			if(s[i].nu == 2) 
			{
				if(s[i].u <= a[2]/2)
				{
					s[i].gr=75;
				}
				else s[i].gr=70;
			}	
			if(s[i].nu == 1) 
			{
				if(s[i].u <= a[1]/2)
				{
					s[i].gr=65;
				}
				else s[i].gr=60;
			}
			if(s[i].nu == 0) 
			{
				s[i].gr=50;
			}
		}
		sort(s,s+n,cmp2);//最后再按记录顺序排序,按原顺序输出
		for( i = 0; i < n; i++)
		{
			printf("%d\n",s[i].gr);
		}

		printf("\n");
	}
	return 0;
}






  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值