每天写一道算法题(3)-ants(POJ 1852)

Description

An army of ants walk on a horizontal pole of length l cm, each with a constant speed of 1 cm/s. When a walking ant reaches an end of the pole, it immediatelly falls off it. When two ants meet they turn back and start walking in opposite directions. We know the original positions of ants on the pole, unfortunately, we do not know the directions in which the ants are walking. Your task is to compute the earliest and the latest possible times needed for all ants to fall off the pole.

Input

The first line of input contains one integer giving the number of cases that follow. The data for each case start with two integer numbers: the length of the pole (in cm) and n, the number of ants residing on the pole. These two numbers are followed by n integers giving the position of each ant on the pole as the distance measured from the left end of the pole, in no particular order. All input integers are not bigger than 1000000 and they are separated by whitespace.

Output

For each case of input, output two numbers separated by a single space. The first number is the earliest possible time when all ants fall off the pole (if the directions of their walks are chosen appropriately) and the second number is the latest possible such time. 

Sample Input

2
10 3
2 6 7
214 7
11 12 7 13 176 23 191

Sample Output

4 8
38 207

有n只蚂蚁在木棍上爬行,每只蚂蚁的速度都是每秒1单位长度,现在给你所有蚂蚁初始的位置(蚂蚁运动方向未定),蚂蚁相遇会掉头反向运动,让你求出所有蚂蚁都·掉下木棍的最短时间和最长时间。 

#include<iostream>
#include<vector>

using namespace std;

int max(int a, int b){
	return a > b ? a : b;
}

int min(int a, int b){
	return a > b ? b : a;
}

int main(){
	int nums;
	cin >> nums;

	while (nums--){
		int n, l;
		int max_time=0, min_time=0;
		vector<int>  v;

		cin >> l >> n;
		v.resize(n);
		for (int i = 0; i < n; i++)
			cin >> v[i];

		for (int i = 0; i < n; i++){
			max_time = max(max_time, (v[i], l - v[i]));
			min_time = max(min_time, min(v[i], l - v[i]));
		}

		cout << min_time << " " << max_time << endl;

	}
	return 0;
}

把这到题拿出来还是因为这道题太经典了, 每次看都会觉得这个分析问题的能力真的太重要了,如何把复杂的问题简单化这个思考方式很重要。

看到这个问题第一印象就是模拟状态,最短时间很好求全部朝着最近的端点走就好了,难点在于最长时间。这里很不好想的就是碰撞后调头这个状态如何模拟,模拟每只蚂蚁的状态求出最长时间的话那么时间复杂度2的N次幂肯定要爆掉。

每只蚂蚁碰撞后调头其实就等于每只蚂蚁可以穿过对方继续往前走,这么一想的话问题马上就简单很多,每只蚂蚁都向时间长的方向走,走的时间最长的就是就是所求的最长时间,碰撞的设定想明白了这个问题也就解决了。

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值