Ants
Time Limit: 1000MS | Memory Limit: 30000K | |
Total Submissions: 14721 | Accepted: 6413 |
Description
An army of ants walk on a horizontal pole of length l cm, each with a constant speed of 1 cm/s. When a walking ant reaches an end of the pole, it immediatelly falls off it. When two ants meet they turn back and start walking in opposite directions. We know the original positions of ants on the pole, unfortunately, we do not know the directions in which the ants are walking. Your task is to compute the earliest and the latest possible times needed for all ants to fall off the pole.
Input
The first line of input contains one integer giving the number of cases that follow. The data for each case start with two integer numbers: the length of the pole (in cm) and n, the number of ants residing on the pole. These two numbers are followed by n integers giving the position of each ant on the pole as the distance measured from the left end of the pole, in no particular order. All input integers are not bigger than 1000000 and they are separated by whitespace.
Output
For each case of input, output two numbers separated by a single space. The first number is the earliest possible time when all ants fall off the pole (if the directions of their walks are chosen appropriately) and the second number is the latest possible such time.
Sample Input
2 10 3 2 6 7 214 7 11 12 7 13 176 23 191
Sample Output
4 8 38 207题意:m只蚂蚁在一根长为n的竹竿上,蚂蚁朝向未知,若两蚂蚁相遇,则往反方向走,问所有蚂蚁都掉下竿用的最长时间和最短时间。
题解:分析,最短时间即为蚂蚁往相距最近的端点走,最长时间为往相距最远的端点走,假设两只蚂蚁相遇,则反向走,由于蚂蚁速度相等,可视为蚂蚁保持原样交错而过(画图一目了然)
代码:
#include<cstdio>
#include<algorithm>
#include<cmath>
using namespace std;
int main(){
int t,n,m,i;
int a[100100];
scanf("%d",&t);
while (t--){
scanf("%d %d",&n,&m);
int time = 0;
int mint=0;int maxt=0;
for (i=0;i<m;i++){
scanf("%d",&a[i]);
mint=max(mint,min(a[i],n-a[i]));
maxt=max(maxt,max(a[i],n-a[i]));
}
printf ("%d %d\n",mint,maxt);
}
return 0;
}