zoj 3710

Friends

Time Limit: 2 Seconds      Memory Limit: 65536 KB

Alice lives in the country where people like to make friends. The friendship is bidirectional and if any two person have no less than k friends in common, they will become friends in several days. Currently, there are totally n people in the country, and m friendship among them. Assume that any new friendship is made only when they have sufficient friends in common mentioned above, you are to tell how many new friendship are made after a sufficiently long time.

Input

There are multiple test cases.

The first lien of the input contains an integer T (about 100) indicating the number of test cases. Then T cases follow. For each case, the first line contains three integers n, m, k (1 ≤ n ≤ 100, 0 ≤ mn×(n-1)/2, 0 ≤ kn, there will be no duplicated friendship) followed by m lines showing the current friendship. The ith friendship contains two integers ui, vi (0 ≤ ui, vi < n, ui ≠ vi) indicating there is friendship between person ui and vi.

Note: The edges in test data are generated randomly.

Output

For each case, print one line containing the answer.

Sample Input

3
4 4 2
0 1
0 2
1 3
2 3
5 5 2
0 1
1 2
2 3
3 4
4 0
5 6 2
0 1
1 2
2 3
3 4
4 0
2 0

Sample Output

2
0
4


题意:给n个人,m个关系,若A和B存在共同K个以上相同好友则两个结成朋友关系,问在原来给出的朋友关系图后新结成的关系有多少对

其实数据不大,暴力一下就行了,也就两种需要考虑的情况,举个例子,第一种是:0跟2结成朋友关系后才能跟1结成关系。第二种是:2跟3结成朋友关系后,1才能跟2结成朋友关系,接着触发0跟1结成朋友关系。

自己写用了一种类似回溯的办法,原本以为这两种考虑到就好了,但后来一直A不掉,看了下范围,k可以等于0,弄了下特判才过掉

#include<stdio.h>
#include<string.h>
#include<queue>
using namespace std;
int ans,n,m,k,E[105][105],vis[105],F[105];
queue<int> Q;
int main(void){
	int T,a,b;
	scanf("%d",&T);
	while(T--){
		memset(E,0,sizeof(E));
		memset(F,-1,sizeof(F));
		scanf("%d%d%d",&n,&m,&k);
		int ans=0;
		while(m--){
			scanf("%d%d",&a,&b);
			E[a][b]=E[b][a]=1;
		}
		if(k==0){
			for(int i=0;i<n;i++)
				for(int j=i+1;j<n;j++)
					if(!E[i][j]){
						ans++;
						E[i][j]=E[j][i]=1;
					}
		}	
		else {
			for(int i=0;i<n;i++){
				if(!Q.empty())
					Q.pop();
				Q.push(i);
				while(!Q.empty()){
					int u=Q.front();
					Q.pop();
					F[u]=0;
					for(int j=0;j<n;j++)
						if(u!=j&&E[u][j])
							vis[F[u]++]=j;
					int flag=1;
					while(flag){
						flag=0;
						for(int j=0;j<n;j++)
							if(j!=u&&E[u][j]!=1&&(F[j]==-1||F[j]>=k))
								for(int l=0,count=0;l<F[u];l++)
									if(E[j][vis[l]]){
										count++;
										if(count>=k){
											E[u][j]=E[j][u]=1;
											ans++;
											flag=1;
											vis[F[u]++]=j;
											if(F[j]!=-1)
												F[j]++;
											if(j<i)
												Q.push(j);
											break;
										}
									}
					}
				}
			}
		}
		printf("%d\n",ans);
	}
	return 0;
}



                
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值