poj2096 期望

3 篇文章 0 订阅

Collecting Bugs
Time Limit: 10000MS Memory Limit: 64000K
Total Submissions: 2387 Accepted: 1151
Case Time Limit: 2000MS Special Judge

Description

Ivan is fond of collecting. Unlike other people who collect post stamps, coins or other material stuff, he collects software bugs. When Ivan gets a new program, he classifies all possible bugs into n categories. Each day he discovers exactly one bug in the program and adds information about it and its category into a spreadsheet. When he finds bugs in all bug categories, he calls the program disgusting, publishes this spreadsheet on his home page, and forgets completely about the program. 
Two companies, Macrosoft and Microhard are in tight competition. Microhard wants to decrease sales of one Macrosoft program. They hire Ivan to prove that the program in question is disgusting. However, Ivan has a complicated problem. This new program has s subcomponents, and finding bugs of all types in each subcomponent would take too long before the target could be reached. So Ivan and Microhard agreed to use a simpler criteria --- Ivan should find at least one bug in each subsystem and at least one bug of each category. 
Macrosoft knows about these plans and it wants to estimate the time that is required for Ivan to call its program disgusting. It's important because the company releases a new version soon, so it can correct its plans and release it quicker. Nobody would be interested in Ivan's opinion about the reliability of the obsolete version. 
A bug found in the program can be of any category with equal probability. Similarly, the bug can be found in any given subsystem with equal probability. Any particular bug cannot belong to two different categories or happen simultaneously in two different subsystems. The number of bugs in the program is almost infinite, so the probability of finding a new bug of some category in some subsystem does not reduce after finding any number of bugs of that category in that subsystem. 
Find an average time (in days of Ivan's work) required to name the program disgusting.

Input

Input file contains two integer numbers, n and s (0 < n, s <= 1 000).

Output

Output the expectation of the Ivan's working days needed to call the program disgusting, accurate to 4 digits after the decimal point.

Sample Input

1 2

Sample Output

3.0000


题意:每一天都会在n个系统中产生1种bug,每个系统产生bug的几率是1/n,产生1种bug的概率为1/s,求找到所有种类的bug且每个系统都有bug所需的天数期望

思路:用dp[i][j]表示,有i个系统找到bug,且已找到j种bug,到结束还需要的步数期望

则下一个状态总共有4种:

①在已有bug的系统中产生已有的bug:dp[i][j]概率为p0=(i/n)*(j/s)

②在没有bug的系统中产生已有的bug:dp[i+1][j]概率为p1=(1-i/n)*(j/s)

③在已有bug的系统中产生未有的bug:dp[i][j+1]概率为p2=(i/n)*(1-j/s)

在已有bug的系统中产生已有的bug:dp[i+1][j+1]概率为p3=(1-i/n)*(1-j/s)

dp[i][j]=p0*(dp[i][j]+1)+p1*(dp[i+1][j]+1)+p2(dp[i][j+1]+1)+p3*(dp[i+1][j+1]+1)

化简出来后p0+p1+p2+p3=1可以拿出来

因为两边都有dp[i][j]所以移过去之后化简为

dp[i][j]=(p1*dp[i+1][j]+p2dp[i][j+1]+p3*dp[i+1][j+1]+1)/(1-p0)

当i=n,j=s时,会停下不会再产生病毒,故dp[n][s]=0,即没有剩余步数

所以可以以它为上界,推到dp[0][0]即为答案

#include<cstdio>
#include<cstring>
double dp[1050][1050];

int main(void){
	int n,s;
	while(~scanf("%d%d",&n,&s)){
		memset(dp,0,sizeof(dp));
		for(int i=n;i>=0;i--)
			for(int j=s;j>=0;j--)
				if(i==n&&j==s) continue;
				else 
				dp[i][j]=(n*s+(n*j-i*j)*dp[i+1][j]+(s*i-i*j)*dp[i][j+1]+(n-i)*(s-j)*dp[i+1][j+1])/(n*s-i*j);
		printf("%lf\n",dp[0][0]);	
	}
} 



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值