1013. Battle Over Cities (25)

It is vitally important to have all the cities connected by highways in a war. If a city is occupied by the enemy, all the highways from/toward that city are closed. We must know immediately if we need to repair any other highways to keep the rest of the cities connected. Given the map of cities which have all the remaining highways marked, you are supposed to tell the number of highways need to be repaired, quickly.

For example, if we have 3 cities and 2 highways connecting city1-city2 and city1-city3. Then if city1 is occupied by the enemy, we must have 1 highway repaired, that is the highway city2-city3.

Input

Each input file contains one test case. Each case starts with a line containing 3 numbers N (<1000), M and K, which are the total number of cities, the number of remaining highways, and the number of cities to be checked, respectively. Then M lines follow, each describes a highway by 2 integers, which are the numbers of the cities the highway connects. The cities are numbered from 1 to N. Finally there is a line containing K numbers, which represent the cities we concern.

Output

For each of the K cities, output in a line the number of highways need to be repaired if that city is lost.

Sample Input
3 2 3
1 2
1 3
1 2 3
Sample Output
1
0

0

题意,主要就是求去掉一个城市后还剩几个连通块,用并查集比较好。注意最后求根并查集还是要用的根findfather,不要用father。

AC代码:

#include <iostream>
#include <vector>
#include <set>
#include <algorithm>
#include <set>
using namespace std;

bool findx(const vector<int>&vec,int x){
		for(unsigned int i=0;i<vec.size();i++)
			if(vec[i]==x) return true;
		return false;
	}



const int maxn=1005;
bool vis[maxn];
int g[maxn][maxn];
int father[maxn];

int findfather(int x){
	int a=x;
	while(x!=father[x]){
		x=father[x];
	}
	while(a!=father[a]){
		int tmp=a;
		a=father[a];
		father[tmp]=x;
	}

	return x;
}

void unionx(int a,int b){
	int fa=findfather(a);
	int fb=findfather(b);

	if(a!=b) father[fb]=fa;
}
int main(){
	freopen("E:\input.txt","r",stdin);
	//memset(g,-1,sizeof(g));

	int M,N,K;

	cin>>N>>M>>K;
//	cout<<N<<M<<K;
	int a,b;
for(int i=1;i<=M;i++){
    cin>>a>>b;
    if(a>b)
    g[b][a]=1;
    else g[a][b]=1;
  }



  for(int m=0;m<K;m++){
    for(int i=1;i<=N;i++){
      father[i]=i;
    }
    cin>>a;
    for(int i=1;i<=N;i++){
      if(i!=a){
      for(int j=N;j>i;j--){
        if(g[i][j]==1&&j!=a){
          unionx(i,j); 
        }
      }
      }
    }
	//
		//for(int i=1;i<=N;i++) cout<<father[i]<<" ";
		cout<<endl;
		vector<int> liantong;
		int cnt=0;
		for(int j=1;j<=N;j++){
			if(j!=a){
			if(!findx(liantong,findfather(j)))
			{
				liantong.push_back(findfather(j));cnt++;}
				}
			}
			cout<<cnt-1<<endl;
		}

	system("PAUSE");
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值