1013 Battle Over Cities

题目来源:PAT (Advanced Level) Practice

It is vitally important to have all the cities connected by highways in a war. If a city is occupied by the enemy, all the highways from/toward that city are closed. We must know immediately if we need to repair any other highways to keep the rest of the cities connected. Given the map of cities which have all the remaining highways marked, you are supposed to tell the number of highways need to be repaired, quickly.

For example, if we have 3 cities and 2 highways connecting city​1​​-city​2​​ and city​1​​-city​3​​. Then if city​1​​ is occupied by the enemy, we must have 1 highway repaired, that is the highway city​2​​-city​3​​.

Input Specification:

Each input file contains one test case. Each case starts with a line containing 3 numbers N (<1000), M and K, which are the total number of cities, the number of remaining highways, and the number of cities to be checked, respectively. Then M lines follow, each describes a highway by 2 integers, which are the numbers of the cities the highway connects. The cities are numbered from 1 to N. Finally there is a line containing K numbers, which represent the cities we concern.

Output Specification:

For each of the K cities, output in a line the number of highways need to be repaired if that city is lost.

Sample Input:

3 2 3
1 2
1 3
1 2 3

Sample Output:

1
0
0

words: 

Battle 战争,战斗        vitally 至关重要的        repair 修理       enemy 敌人       respectively 分别的

题意:

给定n个顶点m条边的连通图,求当某个顶点被删除后,再将剩余的顶点连通在一起需要添加的边的条数,显然当某个顶点被删除后还是连通图则添加的边数为0条;

思路:

1. 由于n小于1000,所以使用邻接矩阵表示连通图;

2. 邻接矩阵创建完后,输入相关的边;

3. 输入要删除的点,在邻接矩阵中删除与该点相连的边,然后求图的连通分支数需要添加的边数等于连通分支数减一

4. 求连通分支数时使用DFS从任一现存顶点开始遍历除删除点外的所有点,若能从1个点出发便能遍历完所有顶点则连通分支数为1,从2两个点出发能遍历完所有顶点则连通分支数位2,依此类推;

5. 邻接矩阵占用的空间较大,在DFS()函数中采用引用方式,否则会使内存超额;

//PAT ad 1013 Battle Over Cities(25 分)
#include <iostream>
using namespace std;
#include <vector>
#define N 1005


int n,m,k;


void DFS(vector<vector<bool> > &adj,int v,bool *vis)	//以v为起点DFS进行遍历 
{
	vis[v]=true;
	for(int w=1;w<=n;w++)
		if(!vis[w]&&adj[v][w]==1)
			DFS(adj, w, vis);		
} 

void abc(vector<vector<bool> > adj,int a)	//丢失点a 
{
	int i,j;
	for(i=1;i<=n;i++)		//删除与丢书点的边 
		adj[i][a]=adj[a][i]=0;

	bool lost[n+1]={false};		//顶点是否存在数组 
	lost[a]=true;
	int connected_branch=0;
	bool vis[n+1]={false};	//访问标记数组 
	for(i=1;i<=n;i++)
	{
		
		if(!lost[i]&&(!vis[i]))	//未丢失 
		{
			DFS(adj,i,vis);
			connected_branch++;	//连通分支数
		}			 
	}	
	cout<<connected_branch-1<<endl;
 } 

int main()
{
	int i,a,b;
	cin>>n>>m>>k;
	vector<vector<bool> > adj(n+1,vector<bool> (n+1,0));
	for(i=0;i<m;i++) 	//input
	{
		cin>>a>>b;
		adj[a][b]=1;
		adj[b][a]=1; 
	} 
	
	while(k--)
	{
		cin>>a;
		abc(adj,a);
	}
	
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值