1020. Tree Traversals (25)

Suppose that all the keys in a binary tree are distinct positive integers. Given the postorder and inorder traversal sequences, you are supposed to output the level order traversal sequence of the corresponding binary tree.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (<=30), the total number of nodes in the binary tree. The second line gives the postorder sequence and the third line gives the inorder sequence. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the level order traversal sequence of the corresponding binary tree. All the numbers in a line must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input:
7
2 3 1 5 7 6 4
1 2 3 4 5 6 7
Sample Output:

4 1 6 3 5 7 2


题意:由后序中序遍历求出层序遍历,先构建树,再求层次遍历。

#include <stdio.h>//1
#include <iostream>
#include <queue>
#include <vector>
using namespace std;

struct Node{
	Node *l,*r;
	int num;
}node[35];

int postseq[35],inseq[35];

Node* func(int pl,int pr,int inl,int inr){
	Node *root=new Node;
	if(pl>pr) {root=NULL; return root;}

	for(int i=inl;i<=inr;i++){
		if(inseq[i]==postseq[pr]){
	
			root->num=inseq[i];	//cout<<"root->num "<<root->num<<endl;
			root->l=func(pl,pl+i-inl-1,inl,i-1);
			root->r=func(pl+i-inl,pr-1,i+1,inr);
			return root;
		}
	}
}
queue<Node*> q;
vector<int> rst;
void preout(Node *root){
	if(root==NULL) return;

	preout(root->l);

	preout(root->r);	
	cout<<root->num;
}

void levelout(Node *root){
	q.push(root);
	while(!q.empty()){
		Node* tmp=q.front();
		rst.push_back(tmp->num);
		if(tmp->l) q.push(tmp->l);
		if(tmp->r) q.push(tmp->r);
		q.pop();
	}
}
int main(){
	//	freopen("E:\input.txt","r",stdin);
	int n,b;
	cin>>n;
	for(int i=0;i<n;i++) cin>>postseq[i];
	for(int i=0;i<n;i++) cin>>inseq[i];
	
	Node *root=func(0,n-1,0,n-1);
	//	cout<<root->num<<endl;
//	preout(root);
	levelout(root);
	for(int i=0;i<rst.size();i++){
		if(i!=0) cout<<" ";
		cout<<rst[i];
	}
}


ac代码:

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值