PAT (Advanced Level) Practice 1144

1144 The Missing Number(20 分)

Given N integers, you are supposed to find the smallest positive integer that is NOT in the given list.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤10​5​​). Then N integers are given in the next line, separated by spaces. All the numbers are in the range of int.

Output Specification:

Print in a line the smallest positive integer that is missing from the input list.

Sample Input:

10
5 -25 9 6 1 3 4 2 5 17

Sample Output:

7

题意:就是找到最小正整数,在输入队列中不存在的。

思路:将<=0的数都过滤掉,然后把剩下的数进行快排即可,然后相邻比较判断就能得出最小的数。

#include<cstdio>
#include<algorithm>
using namespace std;
#define N 100010
int arr[N];
int main(){
	int n;
	scanf("%d", &n);
	int c = 0;
	for(int i = 0;i < n;i++){
		int t;
		scanf("%d", &t);
		if(t <= 0)
			continue;
		arr[c++] = t;
	}
	sort(arr, arr+c);
	int num = arr[0];
	for(int i = 1;i < c;i++){
		if(num != arr[i] && num + 1 != arr[i]){
			break;
		}else{
			num = arr[i];
		}
	}
	printf("%d\n", num + 1);
	return 0;
} 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值