PAT (Advanced Level) Practice 1015

reversible prime in any number system is a prime whose "reverse" in that number system is also a prime. For example in the decimal system 73 is a reversible prime because its reverse 37 is also a prime.

Now given any two positive integers N (< 10^5^) and D (1 < D <= 10), you are supposed to tell if N is a reversible prime with radix D.

Input Specification:

The input file consists of several test cases. Each case occupies a line which contains two integers N and D. The input is finished by a negative N.

Output Specification:

For each test case, print in one line "Yes" if N is a reversible prime with radix D, or "No" if not.

Sample Input:

73 10
23 2
23 10
-2

Sample Output:

Yes
Yes
No

题意:就是指,一个素数在某个进制系统反转转换后还是素数,称为可逆素数。比如13是素数,在二进制里为1101那么反转转换为1011,值为11,也是素数,就称为可逆素数。输入范围小于10^5(可能为0,注意细节) D在(1,10]内。

解析:这题题意有点不好理解,不过题意理解后,就可以容易写出来,先转换为2进制,反转后,转为10进制判断素数即可。

C++

#include<cstdio>
#include<cmath>
int isPrime(int num){
	if(num < 2)return 0;
	int n = (int)sqrt(num);
	for(int i = 2;i <= n;i++){
		if(num % i == 0)return 0;
	}
	return 1;
}

int reverse(int num, int radix){
	int reverse_num = 0;
	while(num){
		int temp = num % radix;
		reverse_num = reverse_num * radix + temp;//如果二进制 *radix就是将reverse_num整体左移一位,再加上当前结果。最后实现的是二进制反转,同理其他进制也是如此 
		num /= radix; 
	}
	return reverse_num;
}
int main(){
	
	while(1){
		int n, d;
		scanf("%d", &n);
		if(n < 0)break;
		scanf("%d", &d);
		if(n == 1 || !isPrime(n)){  
			printf("No\n");
		}else{//else必须有,不然会执行2次!!!!be careful 
			if(isPrime(reverse(n, d))){
				printf("Yes\n");
			}else{
				printf("No\n");
			}
		}
	}
	return 0;
} 




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值