PAT (Advanced Level) Practice 1065

1065 A+B and C (64bit) (20)(20 point(s))

Given three integers A, B and C in [-2^63^, 2^63^], you are supposed to tell whether A+B > C.

Input Specification:

The first line of the input gives the positive number of test cases, T (<=10). Then T test cases follow, each consists of a single line containing three integers A, B and C, separated by single spaces.

Output Specification:

For each test case, output in one line "Case #X: true" if A+B&gtC, or "Case #X: false" otherwise, where X is the case number (starting from 1).

Sample Input:

3
1 2 3
2 3 4
9223372036854775807 -9223372036854775808 0

Sample Output:

Case #1: false
Case #2: true
Case #3: false

题意,输入A和B和C(都在long范围内),请问A+B是否C。

思路:1.要么写个大数,直接相加。

          2.分情况讨论。

            (1) A和B都小于0,A和B都大于0情况,那么只需要通过C-A和B进行比较就能判断。

            (2)A和B异号,那么直接相加即可,不存在溢出。

代码:

#include<cstdio>
#include<cstring>
typedef long long ll;
int main(){
	int n;
	scanf("%d", &n);
	for(int i = 0;i < n;i++){
		ll A, B, C;
		scanf("%lld%lld%lld", &A, &B, &C);
		if(A > 0 && B > 0){
			if(A > C || B > C){
				printf("Case #%d: true", i+1);//A和B有一个大于C,那么A+B肯定大于C 
			}else{ 
				ll result = C - A; //否则,A+B可能大于C也可能小于C,但是存在溢出,于是使用C-A的方式,肯定不会溢出 
				if(B > result){
					printf("Case #%d: true", i+1);
				}else{
					printf("Case #%d: false", i+1);
				}
			}
		}else if(A < 0 && B < 0){//同上 
			if(A < C || B < C){
				printf("Case #%d: false", i+1);
			} else {
				ll result = C - A;
				if(B > result){
					printf("Case #%d: true", i+1);
				}else{
					printf("Case #%d: false", i+1);
				}
			}
		}else{//第三种就是正负相加即可,肯定不存在溢出 
			ll result = A + B;
			if(result > C){
				printf("Case #%d: true", i+1);
			} else {
				printf("Case #%d: false", i+1);
			}
		}
		printf("\n")
	}
	return 0;
} 


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值