pku3468: A Simple Problem with Integers

A Simple Problem with Integers
Time Limit: 5000MS Memory Limit: 131072K
Total Submissions: 44408 Accepted: 12993
Case Time Limit: 2000MS

Description

You have N integers, A1, A2, ... , AN. You need to deal with two kinds of operations. One type of operation is to add some given number to each number in a given interval. The other is to ask for the sum of numbers in a given interval.

Input

The first line contains two numbers N and Q. 1 ≤ N,Q ≤ 100000.
The second line contains N numbers, the initial values of A1, A2, ... , AN. -1000000000 ≤ Ai ≤ 1000000000.
Each of the next Q lines represents an operation.
"C a b c" means adding c to each of Aa, Aa+1, ... , Ab. -10000 ≤ c ≤ 10000.
"Q a b" means querying the sum of Aa, Aa+1, ... , Ab.

Output

You need to answer all Q commands in order. One answer in a line.

Sample Input

10 5
1 2 3 4 5 6 7 8 9 10
Q 4 4
Q 1 10
Q 2 4
C 3 6 3
Q 2 4

Sample Output

4
55
9
15

Hint

The sums may exceed the range of 32-bit integers.

Source

#include <iostream>
#include <cstdio>

using namespace std;

struct node
{
    int l, r;
    __int64 sum, d;
}v[500000];
__int64 A[200000];
int N, Q;

//往上更新
void pushup(int n)
{
    v[n].sum = v[2*n].sum + v[2*n+1].sum;
}
//往下更新
void pushdown(int n)
{
    if (v[n].d != 0)
    {
        v[n*2].d+=v[n].d;
        v[n*2].sum+=(v[n*2].r-v[n*2].l+1)*v[n].d;
        v[n*2+1].d+=v[n].d;
        v[n*2+1].sum+=(v[n*2+1].r-v[n*2+1].l+1)*v[n].d;
        v[n].d=0;
    }
}
//建树
void build(int l, int r, int n)
{
    v[n].l = l;
    v[n].r = r;
    v[n].d = 0;
    if (r == l)
    {
        v[n].sum = A[r];
        return ;
    }
    int mid = (l+r)/2;
    build(l, mid, 2*n);
    build(mid+1, r, 2*n+1);
    pushup(n);
}
void update(int l, int r, int d, int n)
{
    if (l<=v[n].l && v[n].r<=r)
    {
        v[n].d += d;
        v[n].sum += (v[n].r - v[n].l + 1)*d;
        return ;
    }
    pushdown(n);
    int m = (v[n].l+v[n].r)/2;
    if (r <= m)
        update(l, r, d, 2*n);
    else if (l > m)
        update(l, r, d, 2*n+1);
    else
    {
        update(l, m, d, 2*n);
        update(m+1, r, d, 2*n+1);
    }
    pushup(n);
}
__int64 query(int l, int r, int n)
{
    if (l<=v[n].l && v[n].r<=r)
        return v[n].sum;
    pushdown(n);
    int m = (v[n].l + v[n].r)/2;
    if (r <= m)
        return query(l, r, 2*n);
    else if (l > m)
        return query(l, r, 2*n+1);
    else
        return query(l, m, 2*n)+query(m+1, r, 2*n+1);
}
int main()
{
    char ch;
    int a, b, c;
    while (~scanf("%d %d", &N, &Q))
    {
        for (int i=1; i<=N; i++)
            scanf("%I64d", &A[i]);
        build(1, N, 1);
        while (Q--)
        {
            getchar();
            scanf("%c", &ch);
            if (ch == 'Q')
            {
                scanf("%d%d", &a, &b);
                printf("%I64d\n", query(a, b, 1));
            }
            else
            {
                scanf("%d%d%d", &a, &b, &c);
                update(a, b, c, 1);
            }
        }
    }
    return 0;
}





  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值