3212: Pku3468 A Simple Problem with Integers
Time Limit: 1 Sec Memory Limit: 128 MBSubmit: 2019 Solved: 879
[ Submit][ Status][ Discuss]
Description
You have N integers, A1, A2, ... , AN. You need to deal with two kinds of operations. One type of operation is to add some given number to each number in a given interval. The other is to ask for the sum of numbers in a given interval.
Input
The first line contains two numbers N and Q. 1 ≤ N,Q ≤ 100000.
The second line contains N numbers, the initial values of A1, A2, ... , AN. -1000000000 ≤ Ai ≤ 1000000000.
Each of the next Q lines represents an operation.
"C a b c" means adding c to each of Aa, Aa+1, ... , Ab. -10000 ≤ c ≤ 10000.
"Q a b" means querying the sum of Aa, Aa+1, ... , Ab.
Output
You need to answer all Q commands in order. One answer in a line.
Sample Input
Sample Output
做个水题冷静一下。。。
就是区间加和区间查询
直接暴力
#include<stdio.h>
#define LL long long
LL a[100005], sum[100005];
int main(void)
{
char ch;
int n, q, i, x, y, t;
scanf("%d%d", &n, &q);
for(i=1;i<=n;i++)
{
scanf("%lld", &a[i]);
sum[i] = sum[i-1]+a[i];
}
while(q--)
{
scanf(" %c", &ch);
if(ch=='Q')
{
scanf("%d%d", &x, &y);
printf("%lld\n", sum[y]-sum[x-1]);
}
else
{
scanf("%d%d%d", &x, &y, &t);
for(i=x;i<=n;i++)
{
if(i<=y)
a[i] += t;
sum[i] = sum[i-1]+a[i];
}
}
}
return 0;
}