【PAT】A1144 The Missing Number【散列】

Given N integers, you are supposed to find the smallest positive integer that is NOT in the given list.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤10^​5​​ ). Then N integers are given in the next line, separated by spaces. All the numbers are in the range of int.

Output Specification:

Print in a line the smallest positive integer that is missing from the input list.

Sample Input:

10
5 -25 9 6 1 3 4 2 5 17

Sample Output:

7

题意

求给定序列中未出现的最小正整数。

思路

这题最好的解法应该是区间树,但是好在数字的范围不大,使用散列解决,读取序列标记已出现的所有正整数,然后遍历一遍数字范围即可。

代码

#include <cstdio>
#include <algorithm>
#include <climits>
#include <cstring>
using namespace std;
#define MAX_N 100001
bool marked[INT_MAX];
int main() {
    memset(marked, 0, sizeof(bool));
    
    int N;
    scanf("%d", &N);
    for(int i = 0, t; i < N; i++){
        scanf("%d", &t);
        if(t <= 0) continue;// 负数忽略,不影响结果
        marked[t] = true;
    }
    
    for(int i = 1; i <= INT_MAX; i++){
        if(!marked[i]){// 找到未出现最小正整数
            printf("%d", i);
            break;
        }
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值