1110 Complete Binary Tree-PAT甲级

Given a tree, you are supposed to tell if it is a complete binary tree.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤20) which is the total number of nodes in the tree -- and hence the nodes are numbered from 0 to N−1. Then N lines follow, each corresponds to a node, and gives the indices of the left and right children of the node. If the child does not exist, a - will be put at the position. Any pair of children are separated by a space.

Output Specification:

For each case, print in one line YES and the index of the last node if the tree is a complete binary tree, or NO and the index of the root if not. There must be exactly one space separating the word and the number.

Sample Input 1:

9
7 8
- -
- -
- -
0 1
2 3
4 5
- -
- -

Sample Output 1:

YES 8

Sample Input 2:

8
- -
4 5
0 6
- -
2 3
- 7
- -
- -

Sample Output 2:

NO 1

方法:用层次遍历法,遇到第一个为-1的结点,并且此时节点数已经为n个,则是完全二叉树,否则不是

注意输入左右孩子时,用字符串输入,刚开始用的是字符,忽略了大于9的情况

满分代码如下:

#include<bits/stdc++.h>
using namespace std;
const int N=25;
struct node{
	int l=-1,r=-1;
}nd[N];
int vst[N];
int n;
bool level_order(int root,int &t){
	int num=0;
	queue<int>q;
	q.push(root);
	while(!q.empty()){
		int v=q.front();
		q.pop();
		if(v!=-1){
			num++;
			t=v;
		}else{
			return num==n;
		}
		q.push(nd[v].l);
		q.push(nd[v].r);
	}
}
int main(){
	ios::sync_with_stdio(false);
	cin.tie(0);
	cout.tie(0);
	memset(vst,0,sizeof(vst));
	cin>>n;
	for(int i=0;i<n;i++){
		string a,b;
		cin>>a>>b;
		if(a!="-"){
			nd[i].l=stoi(a);
			vst[nd[i].l]=1;
		}
		if(b!="-"){
			nd[i].r=(stoi(b));
			vst[nd[i].r]=1;
		}
	}
	int root,kk;
	for(int i=0;i<n;i++){
		if(!vst[i]){
			root=i;
			break;
		}
	}
	if(level_order(root,kk)){
		cout<<"YES "<<kk<<endl;
	}else{
		cout<<"NO "<<root<<endl;
	}
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值