【PAT】A1053 Path of Equal Weight【树】

Given a non-empty tree with root R, and with weight W​i​​ assigned to each tree node T​i​​. The weight of a path from R to L is defined to be the sum of the weights of all the nodes along the path from R to any leaf node L.

Now given any weighted tree, you are supposed to find all the paths with their weights equal to a given number. For example, let’s consider the tree showed in the following figure: for each node, the upper number is the node ID which is a two-digit number, and the lower number is the weight of that node. Suppose that the given number is 24, then there exists 4 different paths which have the same given weight: {10 5 2 7}, {10 4 10}, {10 3 3 6 2} and {10 3 3 6 2}, which correspond to the red edges in the figure.

Input Specification:

Each input file contains one test case. Each case starts with a line containing 0<N≤100, the number of nodes in a tree, M (<N), the number of non-leaf nodes, and 0<S<2​30​​, the given weight number. The next line contains N positive numbers where W​i​​ (<1000) corresponds to the tree node T​i​​. Then M lines follow, each in the format:

ID K ID[1] ID[2] … ID[K]

where ID is a two-digit number representing a given non-leaf node, K is the number of its children, followed by a sequence of two-digit ID’s of its children. For the sake of simplicity, let us fix the root ID to be 00.

Output Specification:

For each test case, print all the paths with weight S in non-increasing order. Each path occupies a line with printed weights from the root to the leaf in order. All the numbers must be separated by a space with no extra space at the end of the line.

Note: sequence {A​1​​,A​2​​,⋯,A​n​​} is said to be greater than sequence {B​1​​,B​2​​,⋯,B​m​​} if there exists 1≤k<min{n,m} such that A​i​​=B​i​​ for i=1,⋯,k, and A​k+1​​>B​k+1​​.

Sample Input:

20 9 24
10 2 4 3 5 10 2 18 9 7 2 2 1 3 12 1 8 6 2 2
00 4 01 02 03 04
02 1 05
04 2 06 07
03 3 11 12 13
06 1 09
07 2 08 10
16 1 15
13 3 14 16 17
17 2 18 19

Sample Output:

10 5 2 7
10 4 10
10 3 3 6 2
10 3 3 6 2

题意

给出一个带权树和一个目标值,求所有从根结点到叶结点的路径权值和等于目标值的路径。路径按照字典序(数字大的优先级高)输出。

思路

使用dfs层次遍历,为了实现按照字典序输出,我们在读取输入的同时对任一非叶结点的子结点按结点值降序排序,这样遍历的顺序自然符合条件。在dfs中,如果路径权值和大于S,可以return剪枝,记得将当前结点从路径中弹出。

代码

#include <cstdio>
#include <vector>
#include <cmath>
#include <algorithm>
#define MAX_N 100
using namespace std;
vector<int> children[MAX_N], path;
int value[MAX_N], parent[MAX_N];
int N, M, S;
// 按照结点值降序排序
int cmp(int a, int b){
    return value[a] > value[b];
}

// dfs搜索
void dfs(int x, int amount){
    amount += value[x];
    path.push_back(value[x]);
    if(amount > S){
        path.pop_back();
        return;
    }else if(amount == S && children[x].empty()){
        for(int i = 0; i < path.size(); i++){
            if(i > 0)putchar(' ');
            printf("%d", path[i]);
        }
        putchar('\n');
    }
    for(int i = 0, l = (int)children[x].size(); i < l; i++){
        dfs(children[x][i], amount);
    }
    path.pop_back();
}
int main() {
    scanf("%d %d %d", &N, &M, &S);
    
    // 读取输入
    for(int i = 0; i < N; i++){
        scanf("%d", &value[i]);
    }
    for(int i = 0, id, k, t; i < M; i++){
        scanf("%d %d", &id, &k);
        for(int j = 0; j < k; j++){
            scanf("%d", &t);
            parent[t] = id;
            children[id].push_back(t);
        }
        // 对每个结点的子结点进行排序
        sort(children[id].begin(), children[id].end(), cmp);
    }
    
    // 遍历
    dfs(0, 0);
    return 0;
}
  • 4
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值