pat A 1053 Path of Equal Weight (30)(30 分)

15 篇文章 0 订阅

题目简介:

Given a non-empty tree with root R, and with weight W~i~ assigned to each tree node T~i~. The weight of a path from R to L is defined to be the sum of the weights of all the nodes along the path from R to any leaf node L.

Now given any weighted tree, you are supposed to find all the paths with their weights equal to a given number. For example, let's consider the tree showed in Figure 1: for each node, the upper number is the node ID which is a two-digit number, and the lower number is the weight of that node. Suppose that the given number is 24, then there exists 4 different paths which have the same given weight: {10 5 2 7}, {10 4 10}, {10 3 3 6 2} and {10 3 3 6 2}, which correspond to the red edges in Figure 1.

\ Figure 1

Input Specification:

Each input file contains one test case. Each case starts with a line containing 0 < N <= 100, the number of nodes in a tree, M (< N), the number of non-leaf nodes, and 0 < S < 2^30^, the given weight number. The next line contains N positive numbers where W~i~ (&lt1000) corresponds to the tree node T~i~. Then M lines follow, each in the format:

ID K ID[1] ID[2] ... ID[K]

where ID is a two-digit number representing a given non-leaf node, K is the number of its children, followed by a sequence of two-digit ID's of its children. For the sake of simplicity, let us fix the root ID to be 00.

Output Specification:

For each test case, print all the paths with weight S in non-increasing order. Each path occupies a line with printed weights from the root to the leaf in order. All the numbers must be separated by a space with no extra space at the end of the line.

Note: sequence {A~1~, A~2~, ..., A~n~} is said to be greater than sequence {B~1~, B~2~, ..., B~m~} if there exists 1 <= k < min{n, m} such that A~i~ = B~i~ for i=1, ... k, and A~k+1~ > B~k+1~.

Sample Input:

20 9 24
10 2 4 3 5 10 2 18 9 7 2 2 1 3 12 1 8 6 2 2
00 4 01 02 03 04
02 1 05
04 2 06 07
03 3 11 12 13
06 1 09
07 2 08 10
16 1 15
13 3 14 16 17
17 2 18 19

Sample Output:

10 5 2 7
10 4 10
10 3 3 6 2
10 3 3 6 2

算法思路: 

           这道题是为数不多的让我感觉有提升的一道题,刚拿到这道题的时候,完全没有一点思路,不知道应该用什么方式来进行存储,所以我们又回到了,不要着急做题,拿到题先分析一哈。

           首先,题目有第一行有三个输入,总节点数,非叶子节点数,要求权重和。这三个分别代表什么含义呢。

         总节点数就是我们下一行输入的节点的权重的个数,于是我们有了 第一个for循环;非叶子节点数就是之后剩余的行数,于是有了第二个for'循环。

         而且,第二行输入的权重序列和节点下标是完全一致的,因而我们直接使用数组下标来代替节点的标记。

          到此,我们解决了存储节点的问题。

        之后,如何找到符合条件的路径。我们使用dfs。至于如何理解dfs,我们可以类比先序遍历。先访问根节点,然后顺次访问每一棵子树。

        调用子树时,总和加本节点的值,记住,当访问下一个子树时,要将上一棵子树的根节点出栈。

代码展示: 

#include <cstdio>
#include <vector>
#include <algorithm>
using namespace std;
#define MAXLEN 30


struct node{
	int weight;
	vector<int> child; // 直接存放子节点的下标来代替子节点的指针
}tree[MAXLEN];

bool cmp(int a, int b){
	return tree[a].weight>tree[b].weight;
}

vector<int> path;  //存储路径
void DFS(int noflag,int cutSum,int sum){
	//for(int i =0;i < path.size();i++){
	//printf("%d",tree[path[i]].weight);
	//if(i<path.size()-1) printf(" ");
	//else
	//	printf("\n");
	//}
	if(cutSum>sum) return ;
	if(cutSum == sum){
		if(tree[noflag].child.size()!=0) return ;
		for(int i =0;i < path.size();i++){
			printf("%d",tree[path[i]].weight);
			if(i<path.size()-1) printf(" ");
			else
				printf("\n");
		}
		return ;
	}
	for(unsigned i=0;i < tree[noflag].child.size() ;i++){
		int child = tree[noflag].child[i];
		path.push_back(child);
		DFS(child,cutSum+tree[child].weight,sum);
		path.pop_back();
	}

}

int main(){
	int N,nonLeft,sum;
	scanf("%d %d %d",&N,&nonLeft,&sum);
	for(int i = 0;i<N;i++){
		scanf("%d",&tree[i].weight);
	}
	for(int i=0;i<nonLeft;i++){
		int id,size;
		scanf("%d %d",&id,&size);
		for(int j=0;j<size;j++){
			int temp;
			scanf("%d",&temp);  //临时记录子节点
			tree[id].child.push_back(temp);
		}
		sort(tree[id].child.begin(),tree[id].child.end(),cmp);  //将结点从大到小排序,这样先找到的路径肯定为大的路径
	}
	path.push_back(0);
	DFS(0,tree[0].weight,sum);

	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 2
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 2
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值