三角形和矩形
Time Limit: 5 Sec Memory Limit: 128 MB Special JudgeSubmit: 257 Solved: 124
[ Submit][ Status][ Web Board]
Description
Bobo 有一个三角形和一个矩形,他想求他们交的面积。
具体地,三角形和矩形由 8 个整数 x
1,y
1,x
2,y
2,x
3,y
3,x
4,y
4 描述。 表示三角形的顶点坐标是 (x
1,y
1),(x
1,y
2),(x
2,y
1), 矩形的顶点坐标是 (x
3,y
3),(x
3,y
4),(x
4,y
4),(x
4,y
3).
Input
输入包含不超过 30000 组数据。
每组数据的第一行包含 4 个整数 x
1,y
1,x
2,y
2 (x
1≠x
2,y
1≠y
2).
第二行包含 4 个整数 x
3,y
3,x
4,y
4 (x
3<x
4,y
3<y
4).
(0≤x
i,y
i≤10
4)
Output
对于每组数据,输出一个实数表示交的面积。绝对误差或相对误差小于 10
-6 即认为正确。
Sample Input
1 1 3 3
0 0 2 2
0 3 3 1
0 0 2 2
4462 1420 2060 2969
4159 257 8787 2970
Sample Output
1.00000000
0.75000000
439744.13967527
HINT
Source
用三角划分的办法求多边形面积交
#include <iostream>
#include <cstdio>
#include <cstring>
#include <stack>
#include <queue>
#include <cmath>
#include <algorithm>
using namespace std;
const int maxn=555;
const int maxisn=10;
const double eps=1e-8;
const double pi=acos(-1.0);
int dcmp(double x)
{
if(x>eps) return 1;
return x<-eps ? -1 : 0;
}
inline double Sqr(double x)
{
return x*x;
}
struct Point
{
double x,y;
Point()
{
x=y=0;
}
Point(double x,double y):x(x),y(y) {};
friend Point operator + (const Point &a,const Point &b)
{
return Point(a.x+b.x,a.y+b.y);
}
friend Point operator - (const Point &a,const Point &b)
{
return Point(a.x-b.x,a.y-b.y);
}
friend bool operator == (const Point &a,const Point &b)
{
return dcmp(a.x-b.x)==0&&dcmp(a.y-b.y)==0;
}
friend Point operator * (const Point &a,const double &b)
{
return Point(a.x*b,a.y*b);
}
friend Point operator * (const double &a,const Point &b)
{
return Point(a*b.x,a*b.y);
}
friend Point operator / (const Point &a,const double &b)
{
return Point(a.x/b,a.y/b);
}
friend bool operator < (const Point &a, const Point &b)
{
return a.x < b.x || (a.x == b.x && a.y < b.y);
}
inline double dot(const Point &b)const
{
return x*b.x+y*b.y;
}
inline double cross(const Point &b,const Point &c)const
{
return (b.x-x)*(c.y-y)-(c.x-x)*(b.y-y);
}
};
Point LineCross(const Point &a,const Point &b,const Point &c,const Point &d)
{
double u=a.cross(b,c),v=b.cross(a,d);
return Point((c.x*v+d.x*u)/(u+v),(c.y*v+d.y*u)/(u+v));
}
double PolygonArea(Point p[],int n)
{
if(n<3) return 0.0;
double s=p[0].y*(p[n-1].x-p[1].x);
p[n]=p[0];
for(int i=1; i<n; i++)
{
s+=p[i].y*(p[i-1].x-p[i+1].x);
}
return fabs(s*0.5);
}
double CPIA(Point a[],Point b[],int na,int nb)
{
Point p[maxisn],temp[maxisn];
int i,j,tn,sflag,eflag;
a[na]=a[0],b[nb]=b[0];
memcpy(p,b,sizeof(Point)*(nb+1));
for(i=0; i<na&&nb>2; ++i)
{
sflag=dcmp(a[i].cross(a[i+1],p[0]));
for(j=tn=0; j<nb; ++j,sflag=eflag)
{
if(sflag>=0) temp[tn++]=p[j];
eflag=dcmp(a[i].cross(a[i+1],p[j+1]));
if((sflag^eflag)==-2)
temp[tn++]=LineCross(a[i],a[i+1],p[j],p[j+1]);
}
memcpy(p,temp,sizeof(Point)*tn);
nb=tn,p[nb]=p[0];
}
if(nb<3) return 0.0;
return PolygonArea(p,nb);
}
double SPIA(Point a[],Point b[],int na,int nb)
{
int i,j;
Point t1[4],t2[4];
double res=0.0,if_clock_t1,if_clock_t2;
a[na]=t1[0]=a[0];
b[nb]=t2[0]=b[0];
for(i=2; i<na; i++)
{
t1[1]=a[i-1],t1[2]=a[i];
if_clock_t1=dcmp(t1[0].cross(t1[1],t1[2]));
if(if_clock_t1<0) swap(t1[1],t1[2]);
for(j=2; j<nb; j++)
{
t2[1]=b[j-1],t2[2]=b[j];
if_clock_t2=dcmp(t2[0].cross(t2[1],t2[2]));
if(if_clock_t2<0) swap(t2[1],t2[2]);
res+=CPIA(t1,t2,3,3)*if_clock_t1*if_clock_t2;
}
}
return res;
}
Point a[222],b[222];
Point aa[222],bb[222];
int main()
{
double x1,y1,x2,y2;
double x3,y3,x4,y4;
while(~scanf("%lf %lf %lf %lf",&x1,&y1,&x2,&y2))
{
scanf("%lf %lf %lf %lf",&x3,&y3,&x4,&y4);
a[0]=Point(x1,y1);
a[1]=Point(x2,y1);
a[2]=Point(x1,y2);
b[0]=Point(x3,y3);
b[1]=Point(x4,y3);
b[2]=Point(x4,y4);
b[3]=Point(x3,y4);
printf("%.8f\n",fabs(SPIA(a,b,3,4)));
}
return 0;
}
半平面交:
#include <iostream>
#include <cstdio>
#include <cstring>
#include <stack>
#include <queue>
#include <cmath>
#include <algorithm>
#include<complex>
using namespace std;
#define e exp(1.0); //2.718281828
#define mod 1000000007
#define inf 0x3f3f3f3f
typedef long long LL;
#define INF 0x7fffffff
#define zero(x) (((x)>0?(x):(-x))<eps)
const double eps=1e-8;
const double pi=acos(-1.0);
//判断数k的符号 -1负数 1正数 0零
int dcmp(double k)
{
return k<-eps?-1:k>eps?1:0;
}
inline double sqr(double x)
{
return x*x;
}
struct point
{
double x,y;
point() {};
point(double a,double b):x(a),y(b) {};
void input()
{
scanf("%lf %lf",&x,&y);
}
friend point operator + (const point &a,const point &b)
{
return point(a.x+b.x,a.y+b.y);
}
friend point operator - (const point &a,const point &b)
{
return point(a.x-b.x,a.y-b.y);
}
friend bool operator == (const point &a,const point &b)
{
return dcmp(a.x-b.x)==0&&dcmp(a.y-b.y)==0;
}
friend bool operator < (const point &a, const point &b)
{
return a.x < b.x || (a.x == b.x && a.y < b.y);
}
friend point operator * (const point &a,const double &b)
{
return point(a.x*b,a.y*b);
}
friend point operator * (const double &a,const point &b)
{
return point(a*b.x,a*b.y);
}
double norm()
{
return sqrt(sqr(x)+sqr(y));
}
};
//计算两个向量的叉积
double cross(const point &a,const point &b)
{
return a.x*b.y-a.y*b.x;
}
double cross3(point A,point B,point C) //叉乘
{
return (B.x-A.x)*(C.y-A.y)-(B.y-A.y)*(C.x-A.x);
}
//计算两个点的点积
double dot(const point &a,const point &b)
{
return a.x*b.x+a.y*b.y;
}
double dot3(point A,point B,point C) //点乘
{
return (C.x-A.x)*(B.x-A.x)+(C.y-A.y)*(B.y-A.y);
}
//求n边形的面积,多边形上的点要按逆时针的顺序存储在p中
double ConvexPolygonArea(point *p, int n)
{
double area = 0;
for(int i=1; i<n-1; ++i)
area += cross(p[i] - p[0], p[i+1] - p[0]);
return area / 2;
}
//typedef complex<double> point;
//typedef pair<point,point> halfplane;
struct halfplane
{
point a,b;
halfplane() {};
halfplane(point a,point b):a(a),b(b) {};
};
inline double satisfy(point a,halfplane p)
{
return dcmp(cross(a-p.a,p.b-p.a))<=0;
}
point crosspoint(const halfplane &a,const halfplane &b)
{
double k=cross(b.a-b.b,a.a-b.b);
k=k/(k-cross(b.a-b.b,a.b-b.b));
return a.a+(a.b-a.a)*(k);
}
double arg(point p)
{
return arg(complex<double>(p.x,p.y));
}
bool cmp(const halfplane &a,const halfplane &b)
{
int res=dcmp(arg(a.b-a.a)-arg(b.b-b.a));
return res==0? satisfy(a.a,b):res<0;
}
int halfplaneIntersection(halfplane *v,int n,point *out)
{
//sort(v.begin(),v.end(),cmp);
sort(v,v+n,cmp);
deque<halfplane> q;
deque<point> ans;
q.push_back(v[0]);
for(int i=1; i<n; ++i)
{
if(dcmp(arg(v[i].b-v[i].a)-arg(v[i-1].b-v[i-1].a))==0)
{
continue;
}
while(ans.size()>0&&!satisfy(ans.back(),v[i]))
{
ans.pop_back();
q.pop_back();
}
while(ans.size()>0&&!satisfy(ans.front(),v[i]))
{
ans.pop_front();
q.pop_front();
}
ans.push_back(crosspoint(q.back(),v[i]));
q.push_back(v[i]);
}
while(ans.size()>0&&!satisfy(ans.back(),q.front()))
{
ans.pop_back();
q.pop_back();
}
while(ans.size()>0&&!satisfy(ans.front(),q.back()))
{
ans.pop_front();
q.pop_front();
}
ans.push_back(crosspoint(q.back(),q.front()));
int m=0;
while(ans.empty()==false)
{
out[m++]=ans.front();
ans.pop_front();
}
return m;
}
halfplane v[222];
point out[222];
point a[222],b[222];
int main()
{
int n1,n2;
int cas=0;
double x1,y1,x2,y2;
double x3,y3,x4,y4;
while(scanf("%lf %lf %lf %lf",&x1,&y1,&x2,&y2)!=EOF)
{
scanf("%lf %lf %lf %lf",&x3,&y3,&x4,&y4);
a[0]=point(x1,y1);
a[1]=point(x2,y1);
a[2]=point(x1,y2);
int n=0;
if(x1>x2&&y1>y2)
{
v[n++]=halfplane(a[0],a[1]);
v[n++]=halfplane(a[1],a[2]);
v[n++]=halfplane(a[2],a[0]);
}
else if(x1>x2&&y1<y2)
{
v[n++]=halfplane(a[0],a[2]);
v[n++]=halfplane(a[2],a[1]);
v[n++]=halfplane(a[1],a[0]);
}
else if(x1<x2&&y1>y2)
{
v[n++]=halfplane(a[0],a[2]);
v[n++]=halfplane(a[2],a[1]);
v[n++]=halfplane(a[1],a[0]);
}
else if(x1<x2&&y1<y2)
{
v[n++]=halfplane(a[0],a[1]);
v[n++]=halfplane(a[1],a[2]);
v[n++]=halfplane(a[2],a[0]);
}
b[0]=point(x3,y3);
b[1]=point(x4,y3);
b[2]=point(x4,y4);
b[3]=point(x3,y4);
v[n++]=halfplane(b[0],b[1]);
v[n++]=halfplane(b[1],b[2]);
v[n++]=halfplane(b[2],b[3]);
v[n++]=halfplane(b[3],b[0]);
int m=halfplaneIntersection(v,n,out);
// cout<<m<<endl;
printf("%.8f\n",ConvexPolygonArea(out,m));
}
return 0;
}