HDU2489-Minimal Ratio Tree

Minimal Ratio Tree

                                                                                  Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
                                                                                                             Total Submission(s): 4074    Accepted Submission(s): 1264

Problem Description
For a tree, which nodes and edges are all weighted, the ratio of it is calculated according to the following equation.




Given a complete graph of n nodes with all nodes and edges weighted, your task is to find a tree, which is a sub-graph of the original graph, with m nodes and whose ratio is the smallest among all the trees of m nodes in the graph.
 
Input
Input contains multiple test cases. The first line of each test case contains two integers n (2<=n<=15) and m (2<=m<=n), which stands for the number of nodes in the graph and the number of nodes in the minimal ratio tree. Two zeros end the input. The next line contains n numbers which stand for the weight of each node. The following n lines contain a diagonally symmetrical n×n connectivity matrix with each element shows the weight of the edge connecting one node with another. Of course, the diagonal will be all 0, since there is no edge connecting a node with itself.

All the weights of both nodes and edges (except for the ones on the diagonal of the matrix) are integers and in the range of [1, 100].

The figure below illustrates the first test case in sample input. Node 1 and Node 3 form the minimal ratio tree. 

 
Output
For each test case output one line contains a sequence of the m nodes which constructs the minimal ratio tree. Nodes should be arranged in ascending order. If there are several such sequences, pick the one which has the smallest node number; if there's a tie, look at the second smallest node number, etc. Please note that the nodes are numbered from 1 .
 
Sample Input
  
  
3 2 30 20 10 0 6 2 6 0 3 2 3 0 2 2 1 1 0 2 2 0 0 0
 
Sample Output
  
  
1 3 1 2
 
Source


#include <stdio.h>
#include <string.h>
#include <set>
#include <vector>
#include <queue>

using namespace std;

const int INF=0x3f3f3f3f;
int n,m,total;
int chose[16];
int tmp[16];
int a[16],map[16][16];
int dis[16],visit[16];
double mi;

int prim()
{
    int ans=0;
    int x=chose[0];
    for(int i=0;i<=n;i++)
        dis[i]=INF;
    for(int i=0;i<m;i++)
        dis[chose[i]]=map[x][chose[i]];
    memset(visit,0,sizeof(visit));
    visit[x]=1;
    for(int i=1; i<m; i++)
    {
        int mi=INF;
        int k=-1;
        for(int j=0; j<m; j++)
        {
            if(!visit[chose[j]]&&dis[chose[j]]<mi)
            {
                mi=dis[chose[j]];
                k=chose[j];
            }
        }
        if(k!=-1)
        {
            visit[k]=1;
            ans+=mi;
            for(int j=0;j<m; j++)
            {
                x=chose[j];
                if(!visit[x]&&map[k][x]<dis[x])
                {
                    dis[x]=map[k][x];
                }
            }
        }
    }
    return ans;
}

void dfs(int k,int num)
{
    if(num==m)
    {
        total=0;
        for(int i=0; i<m; i++)
        {
            total+=a[chose[i]];
        }
        int sum=prim();
        double k=sum*1.0/total;
        if(k<mi)
        {
            mi=k;
            for(int i=0; i<m; i++)
            {
                tmp[i]=chose[i];
            }
        }
        return;
    }
    if(n-k+1+num<m) return;
    for(int i=k; i<=n; i++)
    {
        chose[num]=i;
        dfs(i+1,num+1);
    }
}

int main()
{
    while(~scanf("%d%d",&n,&m))
    {
        if(n==0&&m==0) break;
        memset(map,0,sizeof(map));
        mi=INF*0.1;
        for(int i=1; i<=n; i++)
            scanf("%d",&a[i]);
        for(int i=1; i<=n; i++)
        {
            for(int j=1; j<=n; j++)
                scanf("%d",&map[i][j]);
        }
        dfs(1,0);
        for(int i=0; i<m-1; i++)
            printf("%d ",tmp[i]);
        printf("%d\n",tmp[m-1]);
    }
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值