HDU1070-Milk

234 篇文章 1 订阅
22 篇文章 0 订阅

Milk

                                                                            Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
                                                                                                     Total Submission(s): 19557    Accepted Submission(s): 5104


Problem Description
Ignatius drinks milk everyday, now he is in the supermarket and he wants to choose a bottle of milk. There are many kinds of milk in the supermarket, so Ignatius wants to know which kind of milk is the cheapest.

Here are some rules:
1. Ignatius will never drink the milk which is produced 6 days ago or earlier. That means if the milk is produced 2005-1-1, Ignatius will never drink this bottle after 2005-1-6(inclusive).
2. Ignatius drinks 200mL milk everyday.
3. If the milk left in the bottle is less than 200mL, Ignatius will throw it away.
4. All the milk in the supermarket is just produced today.

Note that Ignatius only wants to buy one bottle of milk, so if the volumn of a bottle is smaller than 200mL, you should ignore it.
Given some information of milk, your task is to tell Ignatius which milk is the cheapest.
 

Input
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case starts with a single integer N(1<=N<=100) which is the number of kinds of milk. Then N lines follow, each line contains a string S(the length will at most 100 characters) which indicate the brand of milk, then two integers for the brand: P(Yuan) which is the price of a bottle, V(mL) which is the volume of a bottle.
 

Output
For each test case, you should output the brand of the milk which is the cheapest. If there are more than one cheapest brand, you should output the one which has the largest volume.
 

Sample Input
  
  
2 2 Yili 10 500 Mengniu 20 1000 4 Yili 10 500 Mengniu 20 1000 Guangming 1 199 Yanpai 40 10000
 

Sample Output
  
  
Mengniu Mengniu
Hint
In the first case, milk Yili can be drunk for 2 days, it costs 10 Yuan. Milk Mengniu can be drunk for 5 days, it costs 20 Yuan. So Mengniu is the cheapest.In the second case, milk Guangming should be ignored. Milk Yanpai can be drunk for 5 days, but it costs 40 Yuan. So Mengniu is the cheapest.
 

Author
Ignatius.L


目大意:Ignatius喝牛奶,给出一些牛奶的参数,从中选出性价比最高的牛奶。

题目分析:给出的参数有品名、容量、价格。由于一天要喝200ml,不够的扔掉,所以总量不足200ml的可以忽略不计。以5天为期,过期扔掉,所以1000ml以上的统统是够喝5天。总体思想就是按照性价比排序,这里的“性”就是可喝的天数,“价”就是价格,用结构体和快就得。


#include <iostream>
#include <string>
#include <stdio.h>

using namespace std;

struct milk
{
    string s;
    int p;
    int v;
    double e;
    int day;
} d[1000];

int main()
{
    int t,n;
    double mi;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d",&n);
        mi=999999;
        int k=0;
        for(int i=0; i<n; i++)
        {
            cin>>d[i].s>>d[i].p>>d[i].v;
            if(d[i].v<200) continue;
            d[i].day=d[i].v/200;
            if(d[i].day>=6) d[i].day=5;
            d[i].e=1.0*d[i].p/d[i].day;
            if(mi>d[i].e)
            {
                mi=d[i].e;
                k=i;
            }
            if(mi==d[i].e)
            {
                if(d[i].v>d[k].v)
                    k=i;
            }
        }
        cout<<d[k].s<<endl;
    }
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值