HDU 1070 Milk

Problem Description
Ignatius drinks milk everyday, now he is in the supermarket and he wants to choose a bottle of milk. There are many kinds of milk in the supermarket, so Ignatius wants to know which kind of milk is the cheapest.

Here are some rules:
1. Ignatius will never drink the milk which is produced 6 days ago or earlier. That means if the milk is produced 2005-1-1, Ignatius will never drink this bottle after 2005-1-6(inclusive).
2. Ignatius drinks 200mL milk everyday.
3. If the milk left in the bottle is less than 200mL, Ignatius will throw it away.
4. All the milk in the supermarket is just produced today.

Note that Ignatius only wants to buy one bottle of milk, so if the volumn of a bottle is smaller than 200mL, you should ignore it.
Given some information of milk, your task is to tell Ignatius which milk is the cheapest.

Input
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case starts with a single integer N(1<=N<=100) which is the number of kinds of milk. Then N lines follow, each line contains a string S(the length will at most 100 characters) which indicate the brand of milk, then two integers for the brand: P(Yuan) which is the price of a bottle, V(mL) which is the volume of a bottle.

Output
For each test case, you should output the brand of the milk which is the cheapest. If there are more than one cheapest brand, you should output the one which has the largest volume.

Sample Input
  
  
2 2 Yili 10 500 Mengniu 20 1000 4 Yili 10 500 Mengniu 20 1000 Guangming 1 199 Yanpai 40 10000

Sample Output
  
  
Mengniu Mengniu
Hint
In the first case, milk Yili can be drunk for 2 days, it costs 10 Yuan. Milk Mengniu can be drunk for 5 days, it costs 20 Yuan. So Mengniu is the cheapest.In the second case, milk Guangming should be ignored. Milk Yanpai can be drunk for 5 days, but it costs 40 Yuan. So Mengniu is the cheapest.
 
PS:

题目大意:Ignatius喝牛奶,给出一些牛奶的参数,从中选出性价比最高的牛奶。

题目分析:给出的参数有品名、容量、价格。由于一天要喝200ml,不够的扔掉,所以总量不足200ml的可以忽略不计。以5天为期,过期扔掉,所以1000ml以上的统统按1000ml算。总体思想就是按照性价比排序,用结构体很快就得。

 

#include <iostream>
#include <algorithm>
#include <cmath>
using namespace std;
struct node
{
    double v,p;
    double c;
    char brand[1000];
};
double cmp(node a,node b)
{
    if(a.c==b.c)
        return a.v>b.v;
    else
        return a.c>b.c;
}
int main()
{
    node r[1000];
    int n,t;
    cin>>n;
    while(n--)
    {
        cin>>t;
        for(int i=0; i<t; i++)
        {
            cin>>r[i].brand>>r[i].p>>r[i].v;
            if(r[i].v<200)
            {
                i--;//不满足条件的不排列;
                t--;
                continue;
            }
            else if(r[i].v>=1000)
            {
                r[i].c=1000/r[i].p;//>1000的时候按1000算;
            }
            else
            {
                r[i].v=(floor)(r[i].v/200)*200;//如果是399,则按200算;
                r[i].c=r[i].v/r[i].p;
            }

        }
        sort(r,r+t,cmp);
        cout<<r[0].brand<<endl;
    }
    return 0;
}


 

大神代码:
#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
struct milk
{
    char brand[105];
    int days;
    double price,volume;
} m[100];
int cmp(milk a,milk b)
{
    if(a.days*b.price==a.price*b.days)
        return a.volume>b.volume;
    else
        return a.days*b.price>a.price*b.days;
}
int main()
{
    int t,n;
    scanf("%d",&t);
    for(int i=0; i<t; i++)
    {
        scanf("%d",&n);
        for(int j=0; j<n; j++)
        {
            scanf("%s%lf%lf",m[j].brand,&m[j].price,&m[j].volume);
            if(m[j].volume<200)
            {
                j--;
                n--;
                continue;
            }
            m[j].days=(m[j].volume/200)>5?5:m[j].volume/200;
            //printf("%s\n",(m[j].volume/200)>5?"yes":"no");
            //printf("::::%s\t%d\t%d::::\n",m[j].brand,m[j].price,m[j].days);
        }
        sort(m,m+n,cmp);
        if(m[0].volume<200)
            printf("\n");
        else printf("%s\n",m[0].brand);
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值