HDU5748-Bellovin(最长上升子序列)

Bellovin

                                                                             Time Limit: 6000/3000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)
                                                                                                        Total Submission(s): 1219    Accepted Submission(s): 521

Problem Description
Peter has a sequence  a1,a2,...,an  and he define a function on the sequence --  F(a1,a2,...,an)=(f1,f2,...,fn) , where  fi  is the length of the longest increasing subsequence ending with  ai .

Peter would like to find another sequence  b1,b2,...,bn  in such a manner that  F(a1,a2,...,an)  equals to  F(b1,b2,...,bn) . Among all the possible sequences consisting of only positive integers, Peter wants the lexicographically smallest one.

The sequence  a1,a2,...,an  is lexicographically smaller than sequence  b1,b2,...,bn , if there is such number  i  from  1  to  n , that  ak=bk  for  1k<i  and  ai<bi .
 
Input
There are multiple test cases. The first line of input contains an integer  T , indicating the number of test cases. For each test case:

The first contains an integer  n   (1n100000)  -- the length of the sequence. The second line contains  n  integers  a1,a2,...,an   (1ai109) .  

Output
For each test case, output  n  integers  b1,b2,...,bn   (1bi109)  denoting the lexicographically smallest sequence.
 
Sample Input
  
  
3 1 10 5 5 4 3 2 1 3 1 3 5
 
Sample Output
  
  
1 1 1 1 1 1 1 2 3
 
Source


#include <iostream>
#include <stdio.h>
#include <cstring>
#include <algorithm>

using namespace std;

int b[100005],c[100005];
int n;

int main()
{
    int t,data;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d",&n);
        int num=0;
        for(int i=1;i<=n;i++)
        {
            scanf("%d",&data);
            if(i==1) b[++num]=data,c[1]=1;
            else if(data>b[num]) b[++num]=data,c[i]=num;
            else
            {
                int k=lower_bound(b+1,b+1+num,data)-b;
                b[k]=data;
                c[i]=k;
            }
        }
        for(int i=1;i<n;i++)
            printf("%d ",c[i]);
        printf("%d\n",c[n]);
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值