Bellovin -HDU5487


Peter has a sequence  a1,a2,...,an a1,a2,...,an and he define a function on the sequence --  F(a1,a2,...,an)=(f1,f2,...,fn) F(a1,a2,...,an)=(f1,f2,...,fn), where  fi fi is the length of the longest increasing subsequence ending with  ai ai

Peter would like to find another sequence  b1,b2,...,bn b1,b2,...,bn in such a manner that  F(a1,a2,...,an) F(a1,a2,...,an) equals to  F(b1,b2,...,bn) F(b1,b2,...,bn). Among all the possible sequences consisting of only positive integers, Peter wants the lexicographically smallest one. 

The sequence  a1,a2,...,an a1,a2,...,an is lexicographically smaller than sequence  b1,b2,...,bn b1,b2,...,bn, if there is such number  i i from  1 1 to  n n, that  ak=bk ak=bk for  1k<i 1≤k<i and  ai<bi ai<bi.
Input
There are multiple test cases. The first line of input contains an integer  T T, indicating the number of test cases. For each test case: 

The first contains an integer  n n  (1n100000) (1≤n≤100000) -- the length of the sequence. The second line contains  n n integers  a1,a2,...,an a1,a2,...,an  (1ai109) (1≤ai≤109).
Output
For each test case, output  n n integers  b1,b2,...,bn b1,b2,...,bn  (1bi109) (1≤bi≤109) denoting the lexicographically smallest sequence. 
Sample Input
3
1
10
5
5 4 3 2 1
3
1 3 5
Sample Output
1
1 1 1 1 1
1 2 3
这道题题意就是给出一个序列,求出以每个元素结尾的最长子序列的长度,然后按序输出就行

#include <cstdio>  
#include <algorithm>  
#define INF 0x3f3f3f3f 
#define maxx 100000+10
using namespace std;
int dp[maxx],a[maxx],t[maxx]; 
int main()  
{  
    int n,i,j;  
    int T;
	scanf("%d",&T);
    while(T--)  
    {  
		scanf("%d",&n);
        for(i=0;i<n;i++)  
        {  
            scanf("%d",&a[i]);  
            dp[i]=INF;  
        }  
        for(i=0;i<n;i++) 
		{		  
            *lower_bound(dp,dp+n,a[i])=a[i]; 
            t[i]=lower_bound(dp,dp+n,a[i])-dp+1;//减去后腰加上1才是个数
        }
        for(int i = 0; i < n-1; i++)
			printf("%d ",t[i]);	
		printf("%d\n",t[n-1]);
       
    }  
    return 0;  
}   


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值