POJ2142-The Balance(exgcd)

63 篇文章 0 订阅
6 篇文章 0 订阅

The Balance
Time Limit: 5000MS Memory Limit: 65536K
Total Submissions: 6001 Accepted: 2612

Description

Ms. Iyo Kiffa-Australis has a balance and only two kinds of weights to measure a dose of medicine. For example, to measure 200mg of aspirin using 300mg weights and 700mg weights, she can put one 700mg weight on the side of the medicine and three 300mg weights on the opposite side (Figure 1). Although she could put four 300mg weights on the medicine side and two 700mg weights on the other (Figure 2), she would not choose this solution because it is less convenient to use more weights. 
You are asked to help her by calculating how many weights are required. 

Input

The input is a sequence of datasets. A dataset is a line containing three positive integers a, b, and d separated by a space. The following relations hold: a != b, a <= 10000, b <= 10000, and d <= 50000. You may assume that it is possible to measure d mg using a combination of a mg and b mg weights. In other words, you need not consider "no solution" cases. 
The end of the input is indicated by a line containing three zeros separated by a space. It is not a dataset.

Output

The output should be composed of lines, each corresponding to an input dataset (a, b, d). An output line should contain two nonnegative integers x and y separated by a space. They should satisfy the following three conditions. 
  • You can measure dmg using x many amg weights and y many bmg weights. 
  • The total number of weights (x + y) is the smallest among those pairs of nonnegative integers satisfying the previous condition. 
  • The total mass of weights (ax + by) is the smallest among those pairs of nonnegative integers satisfying the previous two conditions.

No extra characters (e.g. extra spaces) should appear in the output.

Sample Input

700 300 200
500 200 300
500 200 500
275 110 330
275 110 385
648 375 4002
3 1 10000
0 0 0

Sample Output

1 3
1 1
1 0
0 3
1 1
49 74
3333 1

Source


题意:有两种类型的砝码,每种的砝码质量a和b给你,现在要求称出质量为d的物品,要求a的数量x和b的数量y最小,以及x+y的值最小。

解题思路:是扩展欧几里得的应用。设ax + by = gcd(a,b),求出x和y的值,因为我们要求ax + by = n的解,所以需要将x y的值乘以n/gcd(a,b)。因为题目中要求x和y的值都要为正,然而,易知,ax + by = gcd(a,b)在a和b都为正数的情况下,x 和 y必有一个数是负的。因此我们需要把x 和 y的值转化为合法的正值。我们先把x转化为正值,易知,把x转化为正值的方式是 x = (x % (b/gcd(a,b))+(b/gcd(a,b)) %(b/gcd(a,b)),这样x就成为最小的正值,我们再根据所求出的x的最小正值求出y的值,则 y = (n – a * x) / b,若求出的y为负值,则把y变正,意思就是砝码放置的位置有左右之分,可以左面的减去右面的,也可以右面的减去左面的。同理,再求出y为最小合法正值时x的解,将这两种情况比较取小的即可。

#include <iostream>
#include <algorithm>
#include <cstdio>
#include <cmath>

using namespace std;

#define ll long long

int exgcd(ll a,int b,int &x,int &y)
{
    if(!b)
    {
        x=1;
        y=0;
        return a;
    }
    int d=exgcd(b,a%b,x,y);
    int tmp=x;
    x=y;
    y=tmp-(a/b)*y;
    return d;
}

int main()
{
    int a,b,d,x,y;
    while(~scanf("%d %d %d",&a,&b,&d))
    {
        if(!a&&!b&&!d) break;
        int d1=exgcd(a,b,x,y);
        x=x*d/d1;
        y=y*d/d1;
        int xx1=(x%(b/d1)+b/d1)%(b/d1);
        int yy1=(d-xx1*a)/b;
        yy1=fabs(yy1);
        int sum=xx1+fabs(yy1);
        int yy2=(y%(a/d1)+a/d1)%(a/d1);
        int xx2=(d-yy2*b)/a;
        xx2=fabs(xx2);
        if(sum>xx2+yy2) printf("%d %d\n",xx2,yy2);
        else printf("%d %d\n",xx1,yy1);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值