HDU1455&&POJ1011-Sticksa

159 篇文章 1 订阅
75 篇文章 0 订阅

 

Sticks

 

                                                                             Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
                                                                                                        Total Submission(s): 9759    Accepted Submission(s): 2900

 

 

Problem Description

George took sticks of the same length and cut them randomly until all parts became at most 50 units long. Now he wants to return sticks to the original state, but he forgot how many sticks he had originally and how long they were originally. Please help him and design a program which computes the smallest possible original length of those sticks. All lengths expressed in units are integers greater than zero. 

 

Input

The input contains blocks of 2 lines. The first line contains the number of sticks parts after cutting, there are at most 64 sticks. The second line contains the lengths of those parts separated by the space. The last line of the file contains zero.

 

Output

The output file contains the smallest possible length of original sticks, one per line. 

 

Sample Input

 

9 5 2 1 5 2 1 5 2 1 4 1 2 3 4 0

 

Sample Output

 

6 5

 

Source

ACM暑期集训队练习赛(七)

 

 

 

题意: n根木棍,要求还原为原木棍,且原木棍等长,问最短长度是多少。

#include <iostream>
#include <cstdio>
#include <cmath>
#include <cstring>
#include <algorithm>
#include <stack>
#include <queue>
#include <vector>
#include <set>
 
using namespace std;
 
int a[110],n,sum,cnt,visit[110],flag;
 
int cmp(int x,int y)
{
    return x>y;
}
 
void dfs(int sum,int x,int length,int pos)
{
    if(x==cnt)
    {
        flag=1;return ;
    }
    for(int i=pos;i<n;i++)
    {
        if(visit[i]) continue;
        if(sum+a[i]<length)
        {
            visit[i]=1;
            dfs(sum+a[i],x,length,i+1);
            if(flag) return ;
            visit[i]=0;
            if(sum==0) return ;
            while(a[i]==a[i+1]) i++;
        }
        else if(sum+a[i]==length)
        {
            visit[i]=1;
            dfs(0,x+1,length,0);
            if(flag) return ;
            visit[i]=0;
        }
    }
}
 
int main()
{
    while(~scanf("%d",&n)&&n)
    {
        sum=0;flag=0;
        for(int i=0;i<n;i++)
        {
            scanf("%d",&a[i]);
            sum+=a[i];
        }
        sort(a,a+n,cmp);
        memset(visit,0,sizeof visit);
        for(int i=a[0];;i++)
        {
            if(sum%i!=0) continue;
            cnt=sum/i;
            dfs(0,1,i,0);
            if(flag){printf("%d\n",i);break;}
        }
    }
    return 0;
}

 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值