POJ2049-Finding Nemo

28 篇文章 0 订阅

Finding Nemo
Time Limit: 2000MS Memory Limit: 30000K
Total Submissions: 9287 Accepted: 2200

Description

Nemo is a naughty boy. One day he went into the deep sea all by himself. Unfortunately, he became lost and couldn't find his way home. Therefore, he sent a signal to his father, Marlin, to ask for help. 
After checking the map, Marlin found that the sea is like a labyrinth with walls and doors. All the walls are parallel to the X-axis or to the Y-axis. The thickness of the walls are assumed to be zero. 
All the doors are opened on the walls and have a length of 1. Marlin cannot go through a wall unless there is a door on the wall. Because going through a door is dangerous (there may be some virulent medusas near the doors), Marlin wants to go through as few doors as he could to find Nemo. 
Figure-1 shows an example of the labyrinth and the path Marlin went through to find Nemo. 

We assume Marlin's initial position is at (0, 0). Given the position of Nemo and the configuration of walls and doors, please write a program to calculate the minimum number of doors Marlin has to go through in order to reach Nemo.

Input

The input consists of several test cases. Each test case is started by two non-negative integers M and N. M represents the number of walls in the labyrinth and N represents the number of doors. 
Then follow M lines, each containing four integers that describe a wall in the following format: 
x y d t 
(x, y) indicates the lower-left point of the wall, d is the direction of the wall -- 0 means it's parallel to the X-axis and 1 means that it's parallel to the Y-axis, and t gives the length of the wall. 
The coordinates of two ends of any wall will be in the range of [1,199]. 
Then there are N lines that give the description of the doors: 
x y d 
x, y, d have the same meaning as the walls. As the doors have fixed length of 1, t is omitted. 
The last line of each case contains two positive float numbers: 
f1 f2 
(f1, f2) gives the position of Nemo. And it will not lie within any wall or door. 
A test case of M = -1 and N = -1 indicates the end of input, and should not be processed.

Output

For each test case, in a separate line, please output the minimum number of doors Marlin has to go through in order to rescue his son. If he can't reach Nemo, output -1.

Sample Input

8 9
1 1 1 3
2 1 1 3
3 1 1 3
4 1 1 3
1 1 0 3
1 2 0 3
1 3 0 3
1 4 0 3
2 1 1
2 2 1
2 3 1
3 1 1
3 2 1
3 3 1
1 2 0
3 3 0
4 3 1
1.5 1.5
4 0
1 1 0 1
1 1 1 1
2 1 1 1
1 2 0 1
1.5 1.7
-1 -1

Sample Output

5
-1

Source

题意:有一片方格区域,由一米的小方格构成,方格的边可能为墙,为不能通过,可能是空白,可能是门,为可以通过,一位人在方格的任意位置坐标,坐标为浮点类型。问另一个人至少通过几个门才能从(0,0)找到他。

#include <iostream>
#include <cstdio>
#include <cmath>
#include <cstring>
#include <algorithm>
#include <stack>
#include <queue>
#include <vector>

using namespace std;

const int INF=0x3f3f3f3f;

int map[300][300][2];
int cnt[300][300];
int maxx,maxy;

struct node
{
    int x,y;
    bool friend operator<(node a,node b)
    {
        return cnt[a.x][a.y]>cnt[b.x][b.y];
    }
};

int BFS(int f1,int f2)
{
    priority_queue<node>q;
    int x,y;
    node pre,next;
    for(int i=0; i<=maxx; i++)
        for(int j=0; j<=maxy; j++)
            cnt[i][j]=INF;
    cnt[0][0]=0;
    pre.x=0;
    pre.y=0;
    q.push(pre);
    while(!q.empty())
    {
        pre=q.top();
        q.pop();
        x=pre.x;
        y=pre.y;
        if(x==f1&&y==f2) return cnt[x][y];
        if(y+1<=maxy&&cnt[x][y+1]>cnt[x][y]+map[x][y+1][0])
        {
            cnt[x][y+1]=cnt[x][y]+map[x][y+1][0];
            next.x=x;
            next.y=y+1;
            q.push(next);
        }
        if(y-1>=0&&cnt[x][y-1]>cnt[x][y]+map[x][y][0])
        {
            cnt[x][y-1]=cnt[x][y]+map[x][y][0];
            next.x=x;
            next.y=y-1;
            q.push(next);
        }
        if(x+1<=maxx&&cnt[x+1][y]>cnt[x][y]+map[x+1][y][1])
        {
            cnt[x+1][y]=cnt[x][y]+map[x+1][y][1];
            next.x=x+1;
            next.y=y;
            q.push(next);
        }
        if(x-1>=0&&cnt[x-1][y]>cnt[x][y]+map[x][y][1])
        {
            cnt[x-1][y]=cnt[x][y]+map[x][y][1];
            next.x=x-1;
            next.y=y;
            q.push(next);
        }
    }
    return -1;
}

int main()
{
    int m,n;
    while(~scanf("%d%d",&m,&n))
    {
        if(m==-1&&n==-1) break;
        int x,y,d,t;
        memset(map,0,sizeof(map));
        memset(cnt,0,sizeof(cnt));
        maxx=-1;
        maxy=-1;
        for(int i=0; i<m; i++)
        {
            scanf("%d %d %d %d",&x,&y,&d,&t);
            for(int j=0; j<t; j++)
            {
                if(d)
                {
                    map[x][y+j][d]=INF;
                    maxx=max(maxx,x);
                    maxy=max(maxy,y+t);
                }
                else
                {
                    map[x+j][y][d]=INF;
                    maxx=max(maxx,x+t);
                    maxy=max(maxy,y);
                }
            }
        }
        for(int i=0; i<n; i++)
        {
            scanf("%d %d %d",&x,&y,&d);
            map[x][y][d]=1;
        }
        double f1,f2;
        scanf("%lf %lf",&f1,&f2);
        if(f1>maxx||f2>maxy||f1<1||f2<1)
        {
            printf("0\n");
            continue;
        }
        printf("%d\n",BFS(f1,f2));
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值