HDU1443-Joseph

216 篇文章 0 订阅
63 篇文章 0 订阅

Joseph

                                                                          Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
                                                                                                     Total Submission(s): 2571    Accepted Submission(s): 1529


Problem Description
The Joseph's problem is notoriously known. For those who are not familiar with the original problem: from among n people, numbered 1, 2, . . ., n, standing in circle every mth is going to be executed and only the life of the last remaining person will be saved. Joseph was smart enough to choose the position of the last remaining person, thus saving his life to give us the message about the incident. For example when n = 6 and m = 5 then the people will be executed in the order 5, 4, 6, 2, 3 and 1 will be saved.

Suppose that there are k good guys and k bad guys. In the circle the first k are good guys and the last k bad guys. You have to determine such minimal m that all the bad guys will be executed before the first good guy. 
 

Input
The input file consists of separate lines containing k. The last line in the input file contains 0. You can suppose that 0 < k < 14. 
 

Output
The output file will consist of separate lines containing m corresponding to k in the input file. 
 

Sample Input
  
  
3 4 0
 

Sample Output
  
  
5 30
 

Source
 
题意: 有k个好人跟k个坏人按顺序坐着,然后按第m个杀人,求出把坏人全部先杀光的m的最小值。
解题思路:在这么多个人中,始终用start跟end来确定好人那个序列的位置。 比如一开始是1 2 3 4 5 6,那么start = 0,end = 3(从0开始计数)当m等于5的时候,kill后就剩下1 2 3 4 6 ,重新拍下序列变成 6 1 2 3 4 ,这时候 start = ((start-m)%n+n)%n; end =  ((end-m)%n+n)%n; n是当前剩下的人数。定完位置之后,kill的位置为kill = (m-1)%n。

#include <iostream>
#include <cstdio>
#include <string>
#include <cstring>
#include <algorithm>
#include <cmath>
#include <queue>
#include <stack>
#include <vector>
#include <set>
#include <map>

using namespace std;

#define LL long long

bool Find(int k,int m)
{
    int s=0,e=k-1;
    int p;
    for(int i=2*k;i>k;i--)
    {
        p=(m-1)%i;
        if(p>=s&&p<=e) return false;
        s=((s-m)%i+i)%i;
        e=((e-m)%i+i)%i;
    }
    return true;
}

int main()
{
    int x[14];
    for(int i=1;i<14;i++)
    {
        for(int j=1;;j++)
        {
            if(Find(i,j))
            {
                x[i]=j;
                break;
            }
        }
    }
    int k;
    while(scanf("%d",&k)&&k)
    {
        printf("%d\n",x[k]);
    }
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值