POJ3281-Dining(最大流)

63 篇文章 0 订阅
16 篇文章 0 订阅

Dining
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 16831 Accepted: 7473

Description

Cows are such finicky eaters. Each cow has a preference for certain foods and drinks, and she will consume no others.

Farmer John has cooked fabulous meals for his cows, but he forgot to check his menu against their preferences. Although he might not be able to stuff everybody, he wants to give a complete meal of both food and drink to as many cows as possible.

Farmer John has cooked F (1 ≤ F ≤ 100) types of foods and prepared D (1 ≤ D ≤ 100) types of drinks. Each of his N (1 ≤ N ≤ 100) cows has decided whether she is willing to eat a particular food or drink a particular drink. Farmer John must assign a food type and a drink type to each cow to maximize the number of cows who get both.

Each dish or drink can only be consumed by one cow (i.e., once food type 2 is assigned to a cow, no other cow can be assigned food type 2).

Input

Line 1: Three space-separated integers:  NF, and  D 
Lines 2.. N+1: Each line  i starts with a two integers  Fi and  Di, the number of dishes that cow  i likes and the number of drinks that cow  i likes. The next  Fi integers denote the dishes that cow  i will eat, and the  Di integers following that denote the drinks that cow  i will drink.

Output

Line 1: A single integer that is the maximum number of cows that can be fed both food and drink that conform to their wishes

Sample Input

4 3 3
2 2 1 2 3 1
2 2 2 3 1 2
2 2 1 3 1 2
2 1 1 3 3

Sample Output

3

Hint

One way to satisfy three cows is: 
Cow 1: no meal 
Cow 2: Food #2, Drink #2 
Cow 3: Food #1, Drink #1 
Cow 4: Food #3, Drink #3 
The pigeon-hole principle tells us we can do no better since there are only three kinds of food or drink. Other test data sets are more challenging, of course.

Source


题意:有N头牛,F个食物,D个饮料。N头牛每头牛有一定的喜好,只喜欢几个食物和饮料。每个食物和饮料只能给一头牛。一头牛只能得到一个食物和饮料。而且一头牛必须同时获得一个食物和一个饮料才能满足。问至多有多少头牛可以获得满足。
解题思路:最大流建图是把食物和饮料放在两端。一头牛拆分成两个点,两点之间的容量为1.喜欢的食物和饮料跟牛建条边,容量为1,加个源点和汇点。源点与食物、饮料和汇点的边容量都是1,表示每种食物和饮料只有一个。


#include <iostream>
#include <cstdio>
#include <cstring>
#include <string>
#include <algorithm>
#include <cmath>
#include <map>
#include <set>
#include <stack>
#include <queue>
#include <vector>
#include <bitset>

using namespace std;

#define LL long long
const int INF = 0x3f3f3f3f;
#define MAXN 500  

struct node
{
	int u, v, next, cap;
} edge[MAXN*MAXN];
int nt[MAXN], s[MAXN], d[MAXN], visit[MAXN];
int cnt;

void init()
{
	cnt = 0;
	memset(s, -1, sizeof(s));
}

void add(int u, int v, int c)
{
	edge[cnt].u = u;
	edge[cnt].v = v;
	edge[cnt].cap = c;
	edge[cnt].next = s[u];
	s[u] = cnt++;
	edge[cnt].u = v;
	edge[cnt].v = u;
	edge[cnt].cap = 0;
	edge[cnt].next = s[v];
	s[v] = cnt++;
}

bool BFS(int ss, int ee)
{
	memset(d, 0, sizeof d);
	d[ss] = 1;
	queue<int>q;
	q.push(ss);
	while (!q.empty())
	{
		int pre = q.front();
		q.pop();
		for (int i = s[pre]; ~i; i = edge[i].next)
		{
			int v = edge[i].v;
			if (edge[i].cap > 0 && !d[v])
			{
				d[v] = d[pre] + 1;
				q.push(v);
			}
		}
	}
	return d[ee];
}

int DFS(int x, int exp, int ee)
{
	if (x == ee||!exp) return exp;
	int temp,flow=0;
	for (int i = nt[x]; ~i ; i = edge[i].next, nt[x] = i)
	{
		int v = edge[i].v;
		if (d[v] == d[x] + 1&&(temp = (DFS(v, min(exp, edge[i].cap), ee))) > 0)
		{
			edge[i].cap -= temp;
			edge[i ^ 1].cap += temp;
			flow += temp;
			exp -= temp;
			if (!exp) break;
		}
	}
	if (!flow) d[x] = 0;
	return flow;
}

int Dinic_flow(int ss, int ee)
{
	int ans = 0;
	while (BFS(ss, ee))
	{
		for (int i = 0; i <= ee; i++) nt[i] = s[i];
		ans+= DFS(ss, INF, ee);
	}
	return ans;
}

int main()
{
	int n, f, d;
	while (~scanf("%d %d %d", &n, &f, &d))
	{
		init();
		int x, y, a;
		for (int i = 1; i <= n; i++)
		{
			scanf("%d %d", &x, &y);
			for (int j = 1; j <= x; j++)
			{
				scanf("%d", &a);
				add(a, f + d + i, 1);
			}
			for (int j = 1; j <= y; j++)
			{
				scanf("%d", &a);
				add(f + d + i + n, a + f, 1);
			}
		}
		for (int i = 1; i <= f; i++)
			add(0, i, 1);
		for (int i = f + 1; i <= f + d; i++)
			add(i, f + d + n + n + 1, 1);
		for (int i = 1; i <= n; i++)
			add(f + d + i, f + d + n + i, 1);
		printf("%d\n", Dinic_flow(0, f + d + n + n + 1));
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值