ZOJ3323-Somali Pirates

120 篇文章 1 订阅

Somali Pirates

Time Limit: 1 Second       Memory Limit: 32768 KB

It is said that the famous Somali Pirates hate digits. So their QQ passwords never contain any digit. Given some lines of candidate passwords, you are asked to delete all the digits in the passwords and print other characters in their original order. So the Somali Pirates can use them as their QQ passwords^^

Input

There are multiple test cases. The first line of input is an integer T (T <= 10) indicating the number of test cases.

Each case contains a line indicating a candidate password. The length of the password is between 1 and 20, inclusive. Besides, the password consists of only digits and English letters.

Output

For each candidate password, delete all the digits and print the remaining characters in a line.

Sample Input

2
BeatLA123
1plus1equals1

Sample Output

BeatLA
plusequals

Author:  HANG, Hang
Source:  The 7th Zhejiang Provincial Collegiate Programming Contest


题意:给你一个字符串,让你除去其中的数字字符


#include <iostream>
#include <cstdio>
#include <string>
#include <cstring>
#include <algorithm>
#include <cmath>
#include <queue>
#include <vector>
#include <set>
#include <stack>
#include <map>
#include <climits>

using namespace std;

#define LL long long
const int INF=0x3f3f3f3f;
const int MAX=100009;

int main()
{
    char ch[1009];
    int t;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%s",ch);
        int len=strlen(ch);
        for(int i=0;i<len;i++)
        {
            if(ch[i]>='0'&&ch[i]<='9') continue;
            printf("%c",ch[i]);
        }
        printf("\n");
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值