HDU1518&&ZOJ1909-Square

75 篇文章 0 订阅

Square

Time Limit : 10000/5000ms (Java/Other)   Memory Limit : 65536/32768K (Java/Other)
Total Submission(s) : 147   Accepted Submission(s) : 51
Font: Times New Roman | Verdana | Georgia
Font Size: ← →

Problem Description

Given a set of sticks of various lengths, is it possible to join them end-to-end to form a square?

Input

The first line of input contains N, the number of test cases. Each test case begins with an integer 4 <= M <= 20, the number of sticks. M integers follow; each gives the length of a stick - an integer between 1 and 10,000.

Output

For each case, output a line containing "yes" if is is possible to form a square; otherwise output "no".

Sample Input

3
4 1 1 1 1
5 10 20 30 40 50
8 1 7 2 6 4 4 3 5

Sample Output

yes
no
yes

Source

University of Waterloo Local Contest 2002.09.21


题意:给出n根短棒,问能否组成一个正方形


#include <stdio.h>
#include <string.h>

int n,sum,l;
int a[30],vis[30];
int flag;

void dfs(int bian,int l,int k)
{
    if(bian==5)
    {
        flag = 1;
        return ;
    }
    if(l == sum) dfs(bian+1,0,0);
    if(flag==1) return ;
    for(int i = k; i<n; i++)
    {
        if(!vis[i] && l+a[i]<=sum)
        {
            vis[i] = 1;
            dfs(bian,a[i]+l,i+1);
            vis[i] = 0;
        }
    }
}

int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        sum = 0;
        scanf("%d",&n);
        for(int i = 0; i<n; i++)
        {
            scanf("%d",&a[i]);
            sum+=a[i];
        }
        if(sum%4!=0)
        {
            printf("no\n");
            continue;
        }
        sum = sum/4;
        memset(vis,0,sizeof(vis));
        flag = 0;
        dfs(1,0,0);
        if(flag) printf("yes\n");
        else printf("no\n");
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值