HDU4723-How Long Do You Have to Draw

22 篇文章 0 订阅

How Long Do You Have to Draw

                                                                    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
                                                                                                 Total Submission(s): 417    Accepted Submission(s): 181


Problem Description
There are two horizontal lines on the  XoY plane. One is y 1 = a, the other is y 2 = b(a < b). On line y 1, there are N points from left to right, the x-coordinate of which are x = c 1, c 2, ... , c N (c 1 < c 2 < ... < c N) respectively. And there are also M points on line y 2 from left to right. The x-coordinate of the M points are x = d 1, d 2, ... d M (d 1 < d 2 < ... < d M) respectively.
Now you can draw segments between the points on y 1 and y 2 by some segments. Each segment should exactly connect one point on y 1 with one point on y 2.
The segments cannot cross with each other. By doing so, these segments, along with y1 and y2, can form some triangles, which have positive areas and have no segments inside them.
The problem is, to get as much triangles as possible, what is the minimum sum of the length of these segments you draw?
 

Input
The first line has a number T (T <= 20) , indicating the number of test cases.
For each test case, first line has two numbers a and b (0 <= a, b <= 10 4), which is the position of y 1 and y 2.
The second line has two numbers N and M (1 <= N, M <= 10 5), which is the number of points on y 1 and y 2.
The third line has N numbers c 1, c 2, .... , c N(0 <= c i < c i+1 <= 10 6), which is the x-coordinate of the N points on line y 1.
The fourth line has M numbers d 1, d 2, ... , d M(0 <= d i < d i+1 <= 10 6), which is the x-coordinate of the M points on line y 2.
 

Output
For test case X, output "Case #X: " first, then output one number, rounded to 0.01, as the minimum total length of the segments you draw.
 

Sample Input
  
  
1 0 1 2 3 1 3 0 2 4
 

Sample Output
  
  
Case #1: 5.66
 

Source
 

Recommend
zhuyuanchen520
 


题意:两条平行线,各有n、m个点。要连一些线,两个端点分别是两条平行线上的点,并且不能交叉。在取得最多三角形的情况下,求最小的总的线的长度。

题解:要保证有最多的三角形得把所有的点都连上。先把两平行线的最左端两点先连上,再依次把两条平行线最左端没连的选距离小的连上。


#include <iostream>  
#include <cstdio>  
#include <string>  
#include <cstring>  
#include <algorithm>  
#include <cmath>  
#include <queue>  
#include <vector>  
#include <set>  
#include <stack>  
#include <map>  
#include <climits>  
#include <functional>  
  
using namespace std;  
  
#define LL long long  
const int INF=0x3f3f3f3f;  
const double exps=1e-8;

double c[100005],d[100005];  
  
int main()  
{  
    int t,n,m,cas=1;  
    double a,b;  
    scanf("%d",&t);  
    while(t--)
	{  
        scanf("%lf%lf",&a,&b);  
        double h=fabs(a-b)*fabs(a-b);  
        scanf("%d%d",&n,&m);  
        for (int i=0;i<n;i++) scanf("%lf",&c[i]);  
        for (int i=0;i<m;i++) scanf("%lf",&d[i]);  
        int x=0,y=0;
        double len=0;  
        while(x<n&&y<m)
		{  
            len+=sqrt(h+fabs(c[x]-d[y])*fabs(c[x]-d[y]));  
            if(x==n-1) y++;  
            else if(y==m-1) x++;  
            else
			{  
                if(fabs(c[x]-d[y+1])<fabs(c[x+1]-d[y])) y++;  
                else x++;  
            }  
        }  
        printf("Case #%d: %.2f\n",cas++,len);  
    }  
    return 0;  
}  

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值