Given a string containing only 'A' - 'Z', we could encode it using the following method:
1. Each sub-string containing k same characters should be encoded to "kX" where "X" is the only character in this sub-string.
2. If the length of the sub-string is 1, '1' should be ignored.
Input
The first line contains an integer N (1 <= N <= 100) which indicates the number of test cases. The next N lines contain N strings. Each string consists of only 'A' - 'Z' and the length is less than 100.
Output
For each test case, output the encoded string in a line.
Sample Input
2
ABC
ABBCCC
Sample Output
ABC
A2B3C
Author: ZHANG, Zheng
Source: Zhejiang Provincial Programming Contest 2005
题意:将给定的字符串中相同的连续的字符串写成由数字+ 一个相应的字符,只有单个字符的就直接打印字符
#include <iostream>
#include <cstdio>
#include <cstring>
#include <cmath>
#include <algorithm>
#include <queue>
#include <set>
#include <stack>
#include <map>
#include <functional>
#include <bitset>
#include <string>
using namespace std;
#define LL long long
#define INF 0x3f3f3f3f
int a[30];
char ch[105];
int main()
{
int t;
scanf("%d",&t);
while(t--)
{
scanf("%s",ch);
int len=strlen(ch);
memset(a,0,sizeof a);
int sum=1;
char s=ch[0];
for(int i=1;i<len;i++)
{
if(ch[i]==s) sum++;
else
{
if(sum==1) printf("%c",s);
else printf("%d%c",sum,s);
sum=1;s=ch[i];
}
}
if(sum==1) printf("%c",s);
else printf("%d%c",sum,s);
printf("\n");
}
return 0;
}