HDU1256-画8

234 篇文章 1 订阅

画8

                                                                         Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
                                                                                                    Total Submission(s): 6220    Accepted Submission(s): 2706


Problem Description
谁画8画的好,画的快,今后就发的快,学业发达,事业发达,祝大家发,发,发.
 

Input
输入的第一行为一个整数N,表示后面有N组数据.
每组数据中有一个字符和一个整数,字符表示画笔,整数(>=5)表示高度.
 

Output
画横线总是一个字符粗,竖线随着总高度每增长6而增加1个字符宽.当总高度从5增加到6时,其竖线宽度从1增长到2.下圈高度不小于上圈高度,但应尽量接近上圈高度,且下圈的内径呈正方形.
每画一个"8"应空一行,但最前和最后都无空行.
 

Sample Input
  
  
2 A 7 B 8
 

Sample Output
  
  
AA AA AA AA AA AA AA AA AA AA AA BBB BB BB BB BB BBB BB BB BB BB BB BB BBB
 

Source
 

Recommend
JGShining
 

#include <iostream>
#include <cstdio>
#include <cstring>
#include <string>
#include <algorithm>
#include <cmath>
#include <map>
#include <set>
#include <stack>
#include <queue>
#include <vector>
#include <bitset>

using namespace std;

#define LL long long
const LL INF = 0x3f3f3f3f3f3f3f3f;
const double pi = acos(-1.0);
const double eps = 1e-8;

int main()
{
	int t, n,cas = 0;
	char a;
	scanf("%d", &t);
	while (t--)
	{
		if (cas++) printf("\n");
		cin >> a >> n;
		int x = n / 6 + 1;
		int y = n - 3;
		int y1, y2;
		if (y % 2 == 0)  y1 = y2 = y / 2;
		else y1 = y / 2, y2 = y / 2 + 1;
		for (int i = 0; i<n; i++)
		{
			if (i == 0 || i == y1 + 1 || i == n - 1)
			{
				for (int j = 0; j<x; j++) printf(" ");
				for (int j = 0; j<y2; j++) printf("%c", a);
				printf("\n");
			}
			else
			{
				for (int j = 0; j<x; j++) printf("%c", a);
				for (int j = 0; j<y2; j++) printf(" ");
				for (int j = 0; j<x; j++) printf("%c", a);
				printf("\n");
			}
		}
	}
	return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值