POJ2456-Aggressive cows

44 篇文章 0 订阅

Aggressive cows
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 14024 Accepted: 6798

Description

Farmer John has built a new long barn, with N (2 <= N <= 100,000) stalls. The stalls are located along a straight line at positions x1,...,xN (0 <= xi <= 1,000,000,000). 

His C (2 <= C <= N) cows don't like this barn layout and become aggressive towards each other once put into a stall. To prevent the cows from hurting each other, FJ want to assign the cows to the stalls, such that the minimum distance between any two of them is as large as possible. What is the largest minimum distance?

Input

* Line 1: Two space-separated integers: N and C 

* Lines 2..N+1: Line i+1 contains an integer stall location, xi

Output

* Line 1: One integer: the largest minimum distance

Sample Input

5 3
1
2
8
4
9

Sample Output

3

Hint

OUTPUT DETAILS: 

FJ can put his 3 cows in the stalls at positions 1, 4 and 8, resulting in a minimum distance of 3. 

Huge input data,scanf is recommended.

Source


题意:有n个牛舍和c头牛,让c头牛住进牛舍,问任意两头牛之间最近距离最大为多少

解题思路:给n个牛舍进行排序,然后二分


#include <iostream>
#include <cstdio>
#include <cstring>
#include <string>
#include <algorithm>
#include <cmath>
#include <map>
#include <cmath>
#include <set>
#include <stack>
#include <queue>
#include <vector>
#include <bitset>
#include <functional>

using namespace std;

#define LL long long
const int INF=0x3f3f3f3f;

int n,k;
int a[100050];

bool check(int x)
{
    int sum=1,xx=a[1];
    for(int i=2;i<=n;i++)
    {
        if(a[i]-xx>=x) sum++,xx=a[i];
        if(sum>=k) break;
    }
    if(sum>=k) return 1;
    else return 0;
}

int main()
{
	while(~scanf("%d%d",&n,&k))
    {
        for(int i=1;i<=n;i++) scanf("%d",&a[i]);
        sort(a+1,a+1+n);
        int l=0,r=INF,ans;
        while(l<=r)
        {
            int mid=(l+r)>>1;
            if(check(mid)) {l=mid+1,ans=mid;}
            else r=mid-1;
        }
        printf("%d\n",ans);
    }
	return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值