POJ3279-Fliptile

159 篇文章 1 订阅
16 篇文章 0 订阅

Fliptile
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 10300 Accepted: 3817

Description

Farmer John knows that an intellectually satisfied cow is a happy cow who will give more milk. He has arranged a brainy activity for cows in which they manipulate an M × N grid (1 ≤ M ≤ 15; 1 ≤ N≤ 15) of square tiles, each of which is colored black on one side and white on the other side.

As one would guess, when a single white tile is flipped, it changes to black; when a single black tile is flipped, it changes to white. The cows are rewarded when they flip the tiles so that each tile has the white side face up. However, the cows have rather large hooves and when they try to flip a certain tile, they also flip all the adjacent tiles (tiles that share a full edge with the flipped tile). Since the flips are tiring, the cows want to minimize the number of flips they have to make.

Help the cows determine the minimum number of flips required, and the locations to flip to achieve that minimum. If there are multiple ways to achieve the task with the minimum amount of flips, return the one with the least lexicographical ordering in the output when considered as a string. If the task is impossible, print one line with the word "IMPOSSIBLE".

Input

Line 1: Two space-separated integers:  M and  N 
Lines 2.. M+1: Line  i+1 describes the colors (left to right) of row i of the grid with  N space-separated integers which are 1 for black and 0 for white

Output

Lines 1.. M: Each line contains  N space-separated integers, each specifying how many times to flip that particular location.

Sample Input

4 4
1 0 0 1
0 1 1 0
0 1 1 0
1 0 0 1

Sample Output

0 0 0 0
1 0 0 1
1 0 0 1
0 0 0 0

Source


题意:给出一个01矩阵,每次可以翻转一个点,其相邻的4个点都被翻转,问最少翻转几次可以全部变为0,并输出每个点被翻了几次

解题思路:枚举第一行的翻转所有翻转情况然后逐行向下更新,如果上一行是1的话,那么下面一行肯定要翻转,最后判断一下,最后一行是不是都是0,如果都是,则维护最小的翻转次数


#include <iostream>
#include <cstdio>
#include <string>
#include <cstring>
#include <algorithm>
#include <cmath>
#include <queue>
#include <stack>
#include <vector>
#include <set>

using namespace std;

#define LL long long
const int INF=0x3f3f3f3f;

int n,m;
int ans[20][20],a[20][20],x[20][20];
int dir[5][2]= {{1,0},{-1,0},{0,1},{0,-1},{0,0}};
int mi;

int check(int xx,int yy)
{
    int res=a[xx][yy];
    for(int i=0; i<5; i++)
    {
        int x1=xx+dir[i][0];
        int y1=yy+dir[i][1];
        if(x1<0||y1<0||x1>=m||y1>=n) continue;
        res+=x[x1][y1];
    }
    return res%2;
}

int solve()
{
    for(int i=1; i<m; i++)
        for(int j=0; j<n; j++)
            if(check(i-1,j)) x[i][j]=1;
    for(int i=0; i<n; i++)
        if(check(m-1,i)) return -1;
    int res=0;
    for(int i=0; i<m; i++)
        for(int j=0; j<n; j++)
            res+=x[i][j];
    return res;
}

int main()
{
    while(~scanf("%d%d",&m,&n))
    {
        for(int i=0; i<m; i++)
            for(int j=0; j<n; j++)
                scanf("%d",&a[i][j]);
        mi=INF;
        for(int i=0; i<(1<<n); i++)
        {
            memset(x,0,sizeof x);
            for(int j=0; j<n; j++)
                x[0][n-1-j]=i>>j&1;
            int res=solve();
            if(res==-1) continue;
            if(mi>res)
            {
                mi=res;
                memcpy(ans,x,sizeof ans);
            }
        }
        if(mi==INF) printf("IMPOSSIBLE\n");
        else
        {
            for(int i=0; i<m; i++)
                for(int j=0; j<n; j++)
                    printf("%d%c",ans[i][j],j==n-1?'\n':' ');
        }
    }
    return 0;
}

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值