POJ1222-EXTENDED LIGHTS OUT

159 篇文章 1 订阅
16 篇文章 0 订阅

EXTENDED LIGHTS OUT
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 10591 Accepted: 6795

Description

In an extended version of the game Lights Out, is a puzzle with 5 rows of 6 buttons each (the actual puzzle has 5 rows of 5 buttons each). Each button has a light. When a button is pressed, that button and each of its (up to four) neighbors above, below, right and left, has the state of its light reversed. (If on, the light is turned off; if off, the light is turned on.) Buttons in the corners change the state of 3 buttons; buttons on an edge change the state of 4 buttons and other buttons change the state of 5. For example, if the buttons marked X on the left below were to be pressed,the display would change to the image on the right. 

The aim of the game is, starting from any initial set of lights on in the display, to press buttons to get the display to a state where all lights are off. When adjacent buttons are pressed, the action of one button can undo the effect of another. For instance, in the display below, pressing buttons marked X in the left display results in the right display.Note that the buttons in row 2 column 3 and row 2 column 5 both change the state of the button in row 2 column 4,so that, in the end, its state is unchanged. 

Note: 
1. It does not matter what order the buttons are pressed. 
2. If a button is pressed a second time, it exactly cancels the effect of the first press, so no button ever need be pressed more than once. 
3. As illustrated in the second diagram, all the lights in the first row may be turned off, by pressing the corresponding buttons in the second row. By repeating this process in each row, all the lights in the first 
four rows may be turned out. Similarly, by pressing buttons in columns 2, 3 ?, all lights in the first 5 columns may be turned off. 
Write a program to solve the puzzle.

Input

The first line of the input is a positive integer n which is the number of puzzles that follow. Each puzzle will be five lines, each of which has six 0 or 1 separated by one or more spaces. A 0 indicates that the light is off, while a 1 indicates that the light is on initially.

Output

For each puzzle, the output consists of a line with the string: "PUZZLE #m", where m is the index of the puzzle in the input file. Following that line, is a puzzle-like display (in the same format as the input) . In this case, 1's indicate buttons that must be pressed to solve the puzzle, while 0 indicate buttons, which are not pressed. There should be exactly one space between each 0 or 1 in the output puzzle-like display.

Sample Input

2
0 1 1 0 1 0
1 0 0 1 1 1
0 0 1 0 0 1
1 0 0 1 0 1
0 1 1 1 0 0
0 0 1 0 1 0
1 0 1 0 1 1
0 0 1 0 1 1
1 0 1 1 0 0
0 1 0 1 0 0

Sample Output

PUZZLE #1
1 0 1 0 0 1
1 1 0 1 0 1
0 0 1 0 1 1
1 0 0 1 0 0
0 1 0 0 0 0
PUZZLE #2
1 0 0 1 1 1
1 1 0 0 0 0
0 0 0 1 0 0
1 1 0 1 0 1
1 0 1 1 0 1

Source


题意:给出一些01状态,按动一个按键与其相邻的4个和它本身的状态会取反,求使其全部变成0的按动方案

解题思路:枚举第一行的方案,然后逐行向下更新,如果上一行是1的话,那么下面一行肯定要翻转,最后判断一下,最后一行是不是都是0,如果都是,则维护最小的翻转次数


#include <iostream>
#include <cstdio>
#include <string>
#include <cstring>
#include <algorithm>
#include <cmath>
#include <queue>
#include <stack>
#include <vector>
#include <set>

using namespace std;

#define LL long long
const int INF=0x3f3f3f3f;

int ans[20][20],a[20][20],x[20][20];
int dir[5][2]= {{1,0},{-1,0},{0,1},{0,-1},{0,0}};
int mi;

int check(int xx,int yy)
{
    int res=a[xx][yy];
    for(int i=0; i<5; i++)
    {
        int x1=xx+dir[i][0];
        int y1=yy+dir[i][1];
        if(x1<0||y1<0||x1>=5||y1>=6) continue;
        res+=x[x1][y1];
    }
    return res%2;
}

int solve()
{
    for(int i=1; i<5; i++)
        for(int j=0; j<6; j++)
            if(check(i-1,j)) x[i][j]=1;
    for(int i=0; i<6; i++)
        if(check(4,i)) return -1;
    int res=0;
    for(int i=0; i<5; i++)
        for(int j=0; j<6; j++)
            res+=x[i][j];
    return res;
}

int main()
{
    int t,cas=0;
    scanf("%d",&t);
    while(t--)
    {

        for(int i=0; i<5; i++)
            for(int j=0; j<6; j++)
                scanf("%d",&a[i][j]);
        mi=INF;
        for(int i=0; i<(1<<6); i++)
        {
            memset(x,0,sizeof x);
            for(int j=0; j<6; j++)
                x[0][5-j]=i>>j&1;
            int res=solve();
            if(res==-1) continue;
            if(mi>res)
            {
                mi=res;
                memcpy(ans,x,sizeof ans);
            }
        }
        printf("PUZZLE #%d\n",++cas);
        if(mi==INF) printf("IMPOSSIBLE\n");
        else
        {
            for(int i=0; i<5; i++)
                for(int j=0; j<6; j++)
                    printf("%d%c",ans[i][j],j==5?'\n':' ');
        }
    }
    return 0;
}

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值