POJ2785-4 Values whose Sum is 0

44 篇文章 0 订阅

4 Values whose Sum is 0
Time Limit: 15000MS Memory Limit: 228000K
Total Submissions: 22072 Accepted: 6686
Case Time Limit: 5000MS

Description

The SUM problem can be formulated as follows: given four lists A, B, C, D of integer values, compute how many quadruplet (a, b, c, d ) ∈ A x B x C x D are such that a + b + c + d = 0 . In the following, we assume that all lists have the same size n .

Input

The first line of the input file contains the size of the lists n (this value can be as large as 4000). We then have n lines containing four integer values (with absolute value as large as 2 28 ) that belong respectively to A, B, C and D .

Output

For each input file, your program has to write the number quadruplets whose sum is zero.

Sample Input

6
-45 22 42 -16
-41 -27 56 30
-36 53 -37 77
-36 30 -75 -46
26 -38 -10 62
-32 -54 -6 45

Sample Output

5

Hint

Sample Explanation: Indeed, the sum of the five following quadruplets is zero: (-45, -27, 42, 30), (26, 30, -10, -46), (-32, 22, 56, -46),(-32, 30, -75, 77), (-32, -54, 56, 30).

Source



题意:给出4组数据,问从每组中选出一个数字使它们的和为0有几种选法

解题思路:将前两组的数字两两组合,后两组的数字两两组合,然后将后两组组成的数字进行排序,暴力枚举前两组的数字形成的数字,二分查询后两组组成的数字


#include <iostream>  
#include <cstdio>  
#include <cstring>  
#include <string>  
#include <algorithm>  
#include <cmath>  
#include <map>  
#include <cmath>  
#include <set>  
#include <stack>  
#include <queue>  
#include <vector>  
#include <bitset>  
#include <functional>  

using namespace std;

#define LL long long  
const int INF = 0x3f3f3f3f;

int n, a[4005], b[4005], c[4005], d[4005], sum1[16000005], sum2[16000005];

int main()
{
	while(~scanf("%d", &n))
	{
		for(int i=0;i<n;i++) scanf("%d%d%d%d", &a[i], &b[i], &c[i], &d[i]);
		int cnt1 = 0, cnt2 = 0;
		for(int i=0; i<n; i++)
			for (int j = 0; j<n; j++)
				sum1[cnt1++] = a[i] + b[j];
		for (int i = 0; i<n; i++)
			for (int j = 0; j<n; j++)
				sum2[cnt2++] = c[i] + d[j];
		int sum = 0;
		sort(sum2, sum2 + cnt2);
		for(int i=0;i<cnt1;i++)
		{
			int l = 0, r = cnt2 - 1,ans=-1;
			while(l<=r)
			{
				int mid = (l + r) >> 1;
				if (sum2[mid] < -sum1[i]) l = mid + 1;
				else if(sum2[mid] > -sum1[i]) r = mid-1;
				else { ans = mid; r = mid - 1; }
			}
			if (ans == -1) continue;
			while (sum2[ans] == -sum1[i] &&ans<cnt2)
			{
				sum++;
				ans++;
			}
		}
		printf("%d\n", sum);
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值