(POJ - 2785)4 Values whose Sum is 0

(POJ - 2785)4 Values whose Sum is 0

Time Limit: 15000MS Memory Limit: 228000K
Total Submissions: 23687 Accepted: 7161
Case Time Limit: 5000MS

Description

The SUM problem can be formulated as follows: given four lists A, B, C, D of integer values, compute how many quadruplet (a, b, c, d ) ∈ A x B x C x D are such that a + b + c + d = 0 . In the following, we assume that all lists have the same size n .

Input

The first line of the input file contains the size of the lists n (this value can be as large as 4000). We then have n lines containing four integer values (with absolute value as large as 228 ) that belong respectively to A, B, C and D .

Output

For each input file, your program has to write the number quadruplets whose sum is zero.

Sample Input

6
-45 22 42 -16
-41 -27 56 30
-36 53 -37 77
-36 30 -75 -46
26 -38 -10 62
-32 -54 -6 45

Sample Output

5

Hint

Sample Explanation: Indeed, the sum of the five following quadruplets is zero: (-45, -27, 42, 30), (26, 30, -10, -46), (-32, 22, 56, -46),(-32, 30, -75, 77), (-32, -54, 56, 30).

题目大意:从4个集合中选取四个数,使他们的和为0,问一个有多少种选法。

思路:赤裸裸的二分。先预处理出前两个集合的和sum1,后两个集合的和sum2。对sum1数组排序,对于每一个sum2数组中的值设为 sum2[i] ,在sum1中二分查找 sum2[i] ,并统计其个数,最后总的个数便是答案。

ps:①函数lower_bound( )在非递减序列[first,last)进行二分查找,返回大于等于val的第一个元素的位置。如果所有元素都小于val,则返回last的位置;②函数upper_bound( )在非递减序列[first,last)进行二分查找,返回大于val的第一个元素的位置。如果所有元素都小于val,则返回last的位置。

#include<cstdio>
#include<algorithm>
using namespace std;

const int maxn=4005;
int a[maxn][4];
int sum1[maxn*maxn],sum2[maxn*maxn];
int p,q;

int main()
{
    int n;
    while(scanf("%d",&n)!=EOF)
    {
        for(int i=0;i<n;i++) scanf("%d%d%d%d",&a[i][0],&a[i][1],&a[i][2],&a[i][3]);
        p=0,q=0;
        for(int i=0;i<n;i++)
            for(int j=0;j<n;j++)
            {
                sum1[p++]=a[i][0]+a[j][1];
                sum2[q++]=a[i][2]+a[j][3];
            }
        sort(sum1,sum1+p);
        int ans=0;
        for(int i=0;i<q;i++)
            ans+=upper_bound(sum1,sum1+p,-sum2[i])-lower_bound(sum1,sum1+p,-sum2[i]);
        printf("%d\n",ans);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值